Showing results for 
Search instead for 
Did you mean: 

BPC 10.1 embedded installation

Former Member
0 Kudos


We would like to get BPC 10.1 embedded (on BW 7.4 SP9) installed, and we went through the following steps:

1. Activate your SAP technical business content

2. Ensure ICF Services are Activated

3. Activate Business Planning and Consolidation Embedded

4. Make Namespace /1BW/ Modifiable (Embedded only)

But we can not reach UI5 web client.

We'are using the appropriate link "http://<PC_server:port>/sap/epm/bpc/web/", and loading bar freezes with "Querying available environments".

We are skeptical now that embedded installation steps may not be enough to run the web client.

Do we need to install something from the classical model as well?


Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos

Hi Sebnem,

We have gone through the same issue regarding BPC configuration and we have found that there is an error with the UI5 version.

We solved the problem by implementing the steps mentioned in note 2283705 (

Please let us know if it worked for you.


Former Member
0 Kudos

Thanks Martin, I did go through that note, but it did not completely resolve my problem.

Turns out we needed  note 2177052 (, which I couldn't find being referenced anywhere in the installation document for BPC 10.1 for NW 7.4.

I implemented the note and all the prerequisites and BPC is now running fine. I also had to reset the cache a couple of times as described in note 1968214 (


Former Member
0 Kudos

Hello, did you manage to resolve your issue? We're experiencing the same issue where it gets stuck on querying environments.

I've already worked through the security guide and created a role with all the Embedded objects in. I even gave all the objects * access.

I've also implemented note 1919631.

0 Kudos

Hi Sebnem,

you don't have to install BPC standard; everything needed for BPC embedded comes with BW. Have you enabled PAK, cf. also note 1919631.

In addition you should check the security guide, so maybe simply some authorization settings are missing.