cancel
Showing results for 
Search instead for 
Did you mean: 

[BOXI R3.1] can't start only the cms

Former Member
0 Kudos

Hi,

Due to a upgrade, The documentation provide to start only the CMS.

In Linux,I have tried :

./ccm.sh -managedstart

Creating session manager...

Logging onto CMS...

err: ERROR Couldn't logon to CMS (STU00152)

err: Error description: The system box.local can be contacted, but there is no Central Management Server running at port 6400.

You have a solution to start this cms on command line ?

Thanks

Gilles

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

thanks

Former Member
0 Kudos

Do you understand what I say ?

The Upgrade documentation (Unix) xi31_sp3_update_inst_en.pdf page 38:

It is recommended that you stop all the BusinessObjects Enterprise servers

except the Central Management Server before installing any update

packages. This can be done from the Central Management Console (CMC).

The only solution is to start all, go to the Central Management Console and stop all servers except CMS.

My question is on the side of command line without go to the CMC.

thanks

gilles

Edited by: Gilles Crebassa on Oct 18, 2010 10:29 AM

joshua_kuhn
Advisor
Advisor
0 Kudos

Yes, I misunderstood your initial question.

There are only two ways to start/stop servers via the command line.

one is to use the 'startservers'/'stopservers' script

two is to use the 'ccm.sh -managedstart' command.

The problem with using the second is you need the SIA running in order to accept the -managedstart switch. The first option issues a start to the SIA and then the SIA goes down the list of servers and starts everything set to "autostart on SIA start". This is a checkbox set within the server page in the CMC.

If you are trying to apply a patch and would like to only have the CMS running, then you'll need to start everything via 'startservers' script. And then login to CMC and stop everything else. You can highlight multiples at once if you need. In Windows you can do this via CMC or CCM. On Linux, you are pretty limited to CMC unless you wanted to do a -managedstop for every individual server.

joshua_kuhn
Advisor
Advisor
0 Kudos

In the <installdir>/bobje folder, run 'startservers' and this will attempt to start all of your XI3.1 services.

./startservers

Once you issue the command, wait a few seconds and check your running processes using ps to see if it started. If it still isn't starting, then you'll need enable tracing to determine why. Note# 1335757 explains the steps to enable tracing for the CMS in XI3.1. It involves creating a new .ini file and placing it in the 'bobje' folder. The CMS will then write its logs to the /bobje/logging directory. Once this .ini is in place, try to restart the CMS again and check the logs.

A couple reasons why the CMS won't start:

1.) port conflict. ie, another process is already running on the default port 6400. using 'netstat' can help determine if anything is using the port.

2.) unable to connect to the CMS repository database. If its unable to connect on startup, the CMS will fail to start. You can try to use the 'cmsdbsetup.sh' script in the bobje folder to repoint the CMS to the datasource you intend to use.

3.) missing dependency files. if the CMS isn't able to load all of its dependencies required to function, the process will fail. This usually requires a reinstall.

When creating the .ini file, make sure it is named - 'boe_cmsd_trace.ini'. And make sure it has the following 6 lines within the textfile. Once added to the /bobje folder the CMS should start tracing within 60 seconds. Be sure to remove the .ini when you're finished otherwise it can affect performance.

active = true;

importance = xs;

alert = true;

severity = 'E';

keep = true;

size = 100 * 1000;

0 Kudos

What kind of upgrade did you exactly do?

What kind of CMS database do you use?

Regards,

Stratos