Showing results for 
Search instead for 
Did you mean: 

bobj undefined

Former Member
0 Kudos

Hi everyone,

I have searched through these forums and found discussions on this error, but every time I try to click on a link the site is telling met either a 404 error or a 500 error. So here's my question which will hopefully be able to be answered in a timely concise manner.

I am using VS2010 to develop a web application that will show Crystal reports. I am running my development machine on XP SP3 with VS 2010.

I downloaded and installed the SAP Crytal Reports version for Visual Studio 2010 - Standard from the business objects website. Once I did that I was able to successfully create and run Crystal reports on my local development machine, no problem, evrything worked great.

So I went to check out the work on my development server, which is also XP SP3 and running IIS 5.0. I published to my development machine using the publish function in VS2010. When I first ran the site, I got an error stating that there were components missing. Fine, no problem. I went back to the business objects site and downloaded/installed the SAP Crystal Reports runtime engine for .NET Framework 4 (32-bit) and when I ran the site, those errors went away.

Great, I thought, now I should be able to run my Crystal reports, no problem. Nope. I get the bobj is undefined error.

I have tried copying the files under the inetpub\wwwroot\aspnet_client directory to my virtual directory as I have seen mentioned in numerous posts, but I am still getting the bobj undefined error. I also tried a solution I found here to no avail:

The code that I am using is very simple on my ASPX page. I simply placed a CrystalReportViewer on my ASPX page with AutoBindData set to true. Then I do simple C# code to do the actual binding as I have seen in many different references. Again, this works perfectly on my local machine.

Every link in every post I have searched here fails to be found on this site.

Eventually this is going to be running on a 64-bit 2008 Server machine with IIS 7.5 . But I can't even get this to work on a simple setup.

Why is this not working? I've spent days researching this issue and am getting really frustrated at what used to be a simple process. Every time I think I find something, I see a link referenced that's dead.

Please help with something that can be clear and concise instead of roundabout and vague.

Thanks in advance

Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Hi Jon,

On the production machine

run process monitor and then run the application till it reproduces the error.

filter the procmon log according to IIS worker process and check where it is looking for 'crystalreportsviewer13' folder.

Then verify if it exists in that location if not copy it from default website and paste it in the custom website folder.

you can also use below code in your web.config to force the application to look for CR viewer files in its own folder

    <sectionGroup name="businessObjects">
      <sectionGroup name="crystalReports">
        <section name="rptBuildProvider" type="CrystalDecisions.Shared.RptBuildProviderHandler, CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304, Custom=null" />
           <section name="crystalReportViewer" type="System.Configuration.NameValueSectionHandler" />

          <add embedRptInResource="true" />
              <add key="ResourceUri" value="~/crystalreportviewers13" />

- Bhushan.

Former Member
0 Kudos

I used your second method already and it did not work. However, I took a very close look and discovered that I was missing the ~ in front of the ResourceUri key.

THANK YOU!!!!!! Now it works!

Answers (0)