cancel
Showing results for 
Search instead for 
Did you mean: 

BO XI R3 Installation: CMS Error

Former Member
0 Kudos

Post Author: chriss77

CA Forum: Deployment

Hello Everyone,

I attempted to install BO XI R3 on a Windows Server 2003, using an existing database - MS SQL Server 2005. The error I received is:

The Central Management Server has failed to start. Press 'Retry' to attempt to start it again or 'Cancel' to skip any actions dependendent on the Central Management Server. (STU000213)

I am currently using an existing database (SQL Server 2005) and created new database u201Ccrystalu201D. I also used the default CMD Port: 6400 for the BO Administrator. I have added u201Ccrystalu201D in the ODBC System DSN.

After several tries, it was able to continue and complete the installation. When I logged in to the Central Management Console:

Error: Server fls-crystalsrvr:6400 not found or server may be down (FWM 01003) null.

Does this error got something to do with NOT setting the MSSQL Server 2005 to UTF-8? The Install Guide says: For an MS SQL Server database, there are no specific parameters, other than setting of UTF-8 that are crucial for Business Objects Enterprise to work...."

Has anyone done a similar install wih MS SQL Server 2005 before? How is the UTF-8 set? Did you use collation, script?

Any feedback on this issue is welcome.

Thanks so much in advance.

Chris

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Post Author: thinky

CA Forum: Deployment

Hi chriss77We got the same error, obviously the setup get's confused if you specifiy a Administrator password (which is a new option in XI 3.0 setup). THe problem is, that the setup tries to start and login to the CMS during the setup, but at this moment, the Admin password is still empty. Nevertheless, the log files show (at least in our case), that the setup tries to login to the CMS with the password specified within the setup dialog. 28.05.2008, 11:38:04:

RunRedistProgram("C:\temp\BOE\package\jdk\bin\javaw.exe" -jar

"C:\temp\BOE\package\cmslogon\cmslogon.jar"

"SVZHCR102:6400" Administrator "gr8boxi" secEnterprise

"C:\DOCUME1\ecrystal\LOCALS1\Temp\cmslogon.log"). Return value 2In the error message with the "Retry" button, just keep this for a moment, and open the command line: and try to start the CMS manually:

D:\BO120\BusinessObjects Enterprise

12.0\win32_x86>cms.exe u2013name SVZHCR102.cms u2013port 6400 u2013fg u2013dbinfo u201ED:\BO120\BusinessObjects

Enterprise 12.0\win32_x86\_boe_SVZHCR102.dbinfou201CIf the CMS-database is setup for the first time, you don't yet have a license key code. For this, you can use the javascript found in the win32_x86, addlicensekey.js to add the license key manually. Afterwards, you need to open Desktop Intelligence (probably on a other machine, just do a client setup there), login to the now started CMS using Administrator and the still blank password. And within Desktop Intelligence under "Tools" you can change the Administrators password to the value you've set in the setup dialog (which is as well visible in the log file above).On our side, after all these steps, we could click "retry " and the setup finished the installation without problems.Hope this helps.Raphael

Former Member
0 Kudos

Post Author: mstockwell

CA Forum: Deployment

I had many issues installing BOXI 3.0 with SQL Server 2005, untill I realized my machine name starts with number. The routine that creates the repository uses the machine name as a variable, and SQL server doesn't llike column names that start with a number. I had to rename my machine to start with letter. Install worked ok with MySQL though with old name. The Server Intelligence Agent won't let you name a node with leading number.

Two things to check:

The CMS (Server Intelligence Agent actually) will start with local SYSTEM account by default. If the SQL Server is located on different machine the system account will not have rights to DB. Most DBA's won't add a local system account to a server as a login, so you have two options: install with default MySQL on local machine, then change SIA to use global domain account and migrate database. Or use SQL Server named account (not integrated authentication).

For trouble shooting I turned on ODBC tracing via ODBC manager. Make sure to check off "all identities" to get system calls. From this I saw SQL that was generating my machine name error.

Don't think UTF is problem. MS uses Collation to specify sort order, any nvarchar fields are unicode anyway. Most of CMS repo is image/binary data, so wouldn't be affected. See http://support.microsoft.com/kb/232580