cancel
Showing results for 
Search instead for 
Did you mean: 

[BIG PROBLEM] SAP Host Agent cannot connect to SYSTEMDB

symon_braunbaer
Participant
0 Kudos
442

Dear Experts,

I am totally nuts about the following problem:

# /usr/sap/hostctrl/exe/saphostctrl -function ListDatabases

The passwords of <SID>adm, SYSTEM in SYSTEMDB and SAPDBCTRL are 100% correct, tried them all out.

SAP Note 

2023587 - Maintaining SAP HANA user store using SetDatabaseProperty for SAP Host Agent

is NOT helping

SAP Note 

2621457 - hdbconnectivity failure after upgrade to 2.0

is NOT helping

Please kindly advise how to get this solved.

symon_braunbaer_0-1713483595170.png

kashyap_shah3
Contributor
0 Kudos

Hello,

Could you please elaborate on symptom, what problem you see, where. Appeciate that you are trying to avoid to reinvent the wheel and so listed your troubleshotting steps but it seems to confuse things, at least for me. I am not sure the screenshot that you havegiven is running what command from where. Also, is it secure connection (HTTPS) between Host agent and HANA? If yes, have both, agent and HANA got same root certificate installed or trust established by any other mans?

Thanks.

View Entire Topic
symon_braunbaer
Participant
0 Kudos

Any update please ? Any ideas please ?

This is hindering us tremendously, as several automation scripts are failing due to this problem !!
We need to get this sorted out... Thanks a lot!

kashyap_shah3
Contributor
0 Kudos
have you looked at my reply from Monday to your comment?
symon_braunbaer
Participant
0 Kudos
Hello kashyap_shah3, this new layout is very misleading and I think some of the contents in this thread got lost. If you mean your answer from 19-Apr-2024, the yes, I have checked it and unfortunately this is not useful, as we do not have the ; character in our Hana password. Any other ideas please ?
kashyap_shah3
Contributor
0 Kudos

No, long reply that says 2 weeks ago. I am pasting it here as well:

I'm still interested to see the symptom. I understand, as you have provided, output of ListDatabases for saphostctrl have got some errors towards the end. At beginning, it's detecting HANA components alright. So I want to understand what it stops you doing.
If you cehck Agent Admin on your Solution Manager system, is Host agent Green there: http(s)://<SolMan_FQDN>:5<Java_App_Instance_number><00_for_HTTP/01_for_HTTPS>/smd/AgentAdmin --> SAP Host Agent --> HANA FQDN under Agent name
How about Diagnostics agent: http(s)://<SolMan_FQDN>:5<Java_App_Instance_number><00_for_HTTP/01_for_HTTPS>/smd/AgentAdmin --> Agents --> HANA FQDN under Connected Agents - Full Host Name
Do you have outside discover setup by host agent or diagnostics agent? You can find that in your LMDB (on SolMan) --> Hosts --> HANA short hostname against Host Name --> Display --> besides Host Name, it will show "Supplied by Outside Discovery (SAP Host Agent)" if outside discovery by host agent is configured.
Moreover, if you have systems registering to SLD and from there going to LMDB, then you need to look at that as well.