cancel
Showing results for 
Search instead for 
Did you mean: 

BExAddin Fehler: Attempted to read or write protected memory.

njm_lukassen
Explorer
0 Kudos

Dear Community,

Since installation of BEx 7.40 patch 800 and recently version 7.50 I sometimes get this error screen when starting Excel with the BEXAddin enabled:

--------------------------- BExAddin --------------------------- Fehler: Attempted to read or write protected memory. This is often an indication that other memory is corrupt. at Microsoft.VisualBasic.CompilerServices.LateBinding.InternalLateSet(Object o, Type& objType, String name, Object[] args, String[] paramnames, Boolean OptimisticSet, CallType UseCallType) at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateSet(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments, Boolean OptimisticSet, Boolean RValueBase, CallType CallType) at Microsoft.VisualBasic.CompilerServices.NewLateBinding.LateSet(Object Instance, Type Type, String MemberName, Object[] Arguments, String[] ArgumentNames, Type[] TypeArguments) at com.sap.bi.et.analyzer.addin.BExConnect.SetExcel(Object iExcel) --------------------------- OK ---------------------------

If I start via the BEx Analyzer icon(starts an instance of Excel) then it does not happen, only when starting Excel directly wit the pulgin enabled.

I tried to search similar issues but could not find anything about it.

I think it is something connected to .Net Framewrok right?

Any feedback on this is very welcome!

Reg.,

Niels

njm_lukassen
Explorer
0 Kudos

Hi Emin,

You mean this string"ID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}" ? Well like I described in the steps. Otherwise I do not understand your question.

Accepted Solutions (0)

Answers (3)

Answers (3)

former_member299693
Discoverer
0 Kudos

Hey folks,

please notice SAP Note 2536239!

Regards

Andreas

0 Kudos

Hi,

Are you able to find the solution to this issue? We are having same issue. I tried to follow as above but couldn't find the applID.

Thanks,

MM

njm_lukassen
Explorer
0 Kudos

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

{D63*****}

and APPID

{9CA*****}

to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
3. Scroll down and find the application ID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} -> Right Click -> Properties and select the Security tab.
3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
4. Restart the application Service linked to this Application ID or restart the server and monitor