cancel
Showing results for 
Search instead for 
Did you mean: 

BEx 0I_CMNTH do not display all infoprovider value

0 Kudos

Hi all,

i have an issue with one query (builded on Multiprovider) using the variable 0I_CMNTH for the IO Ocalmonth.

The variable do not display all infoprovider value, i mean in the LOV the date for 01.2015, 02.2015 and 03.2015 not show up and data ara available in the Infoprovider.

the poin is that we use the same variable 0I_CMNTH for the IO Ocalmonth builded on the same infoprovidere that works correctly

I

I also checked all the query and variable properties, and are the same for both queries.

Any ideas??

Accepted Solutions (1)

Accepted Solutions (1)

KodandaPani_KV
Active Contributor
0 Kudos

Hi

while seeing the LOV some where you are rescritcing the month values.

check the any global leve filters and local filters  on calmonth.

are you sure both queries developed on the same multi provider? if yes cross check with the cube vlaeus.

also check the 0CALMONTH multi provide assingement.

-Phani.

0 Kudos

SOLVED.

forget about it

the query has restricted key figures for specific Infocube and the 0I_CMNTH variable, and there is non data for 2015 for the restricted value.

thx to all for the consideration and support.

Answers (1)

Answers (1)

swati_gawade
Contributor
0 Kudos

Hi Alessadro,

in your query please check the extended properties for infoobject 0Calmonth.

If you want to disply only the values from infoprovider then please select the option 'Only values in Infoprovider' in 'Filter value selection at Query execution'.

Hope this helps,

-swati.

0 Kudos

Hi Swati gawade,

the flag for the IO 0calmonth's properties are as  you show me.

This Behavior is really strange because:

-  We use the same variable -> 0I_CMNTH for 2 queries on the same multiprovider and one query work correctly and the other one do not work


Loed
Active Contributor
0 Kudos

Hi Alessandro,

Perhaps you have filter in CALMONTH in the query where January - March 2015 can't be found?

Because if you have, like April - December 2014 only, you really can't see the January - March 2015..

Kindly compare the filters found in the two (2) queries..

Regards,

Loed

0 Kudos

Hi Loed,

the filters are the same on both queries, so i have data for January - March 2015.

By the way the queries are on the same multiprovider.

At last i want try to transport the query from D to Q and in Production...the query should be corrupted.

I will keet the forum update

Loed
Active Contributor
0 Kudos

Hi Alessandro,

Yeah, just try to re-transport the query then post here for updates..

Regards,

Loed

swati_gawade
Contributor
0 Kudos


Hi Alessandro,

Can you please share screenshots of the properties of both variables? also share the screenshot of extended property tab of IO CALMONTH.

Does your query have any default restriction on any characteristic?

-Swati.