Showing results for 
Search instead for 
Did you mean: 

BAPI returns always 0 record

Former Member
0 Kudos


We created in SAP(SE37) two functions to provide records from table BAPIORDERS Table.

Both functions are RFC enabled.

The functions are called with .net connector 2.0 and visual studio 2003 Ver.7.1.3088. Also we use the patch available in OSS note 506603.

Calling of function 1 works fine. We get the correct record count and the according records.

Function 2 returns always 0 as record count and in according to this, no records.

The non table parameters are ok and there are no errors reported. The selection parameters are OK

Same result when we build a proxy with both or only one of the functions.

No others functions added to the proxy.

Thanks for help!

Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Two possible reason:

1. The function returns values, but they are not correctly unmarshalled. This could happen if something with the XML attributes is wrong.

2. The function doesn't return anything.

To find out if it's 1. or 2., you could use a network sniffer or turn on RFC trace. Check if there is the expected ammount of data is really returned. If 2. turns out to be the case, I recommend to use Abap-Debug feature to see if the paramter really arrive in the for as expected and why the function doesn't return anything.

Former Member
0 Kudos

Thank you for your help.

I turned on RFC trace. And there were no data in the table. I solved the problem, the RFC User did not have enough authorisation for the second function.

Answers (0)