cancel
Showing results for 
Search instead for 
Did you mean: 

Background image disappeared in Windows 11

yumb
Explorer
0 Kudos

Hello, I use SAP Crystal Reports for Visual Studio to create reports in our application.

The reports work good in Windows 7 and Windows 10, but have a problem in Windows 11 - the background image is not shown (disappeared). The identical problem on several Windows 11 computers, customers and testing machines.

What can be a problem and possible solution / workaround?

The image appear as "OLE Object" in SAP Crystal Reports 2016 Developer (SAP Crystal Reports 2016 Support Pack 4, Version 14.2.4.2410)

That we see in Windows 7 /10:

That we see in Windows 11:

DellSC
Active Contributor
0 Kudos

Which version of Crystal and/or the Crystal for Visual Studio SDK are you using?

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Yuri,

Thanks for reporting it, R&D is aware of the issue.

Partial work around:

We have noticed this OLE Object(Picture) issue on Windows 11 already…

If you click Insert->OLE Object… from menu, select the picture file from disk.

Then insert this OLE Object(Picture) into report, it will display correctly on any OS except Windows 11.

So there’s a workaround: use menu Insert->Picture to insert a picture into report.

Looks like customer just used OLE Object(picture), not the Blob field from database. If the picture is a Blob field, it will NOT displayed as well on Windows 11. And there’s no workaround for blob field…

I'll create an internal incident and hopefully they have it fixed before SP 32 comes out.

Escalated now: 52561/2022 / Crystal Reports for Visual Studio - OLE Object(Picture) issue on Windows 11

See KBA for solution: 3204578 - Crystal Reports and Crystal Reports for Visual studio - Windows 11 OLE Objects formatting incorrect or missing image

Don

yumb
Explorer
0 Kudos

Hi Don,

Thank you for reply. I have the real image in report (from file, not from the Blob field).

So I solved the problem by converting the existing OLE Image objects from "PBrush" type to "Picture (Device Independent Bitmap)"
(Right Click on OLE object -> Bitmap Image Object -> Convert... -> Convert to: Picture (Device Independent Bitmap).
This solved the problem and images are shown in Windows 11. Re-insert of images was not required.

FYI, there is also a workaround without changing the report itself, but configuring Windows (changing the registry) instead, described here: https://techcommunity.microsoft.com/t5/report-an-issue/pasting-an-image-into-a-ms-access-image-ole-o.... Images were shown after applying the both registry files inside OLEFix.zip. But this way has its own drawbacks of dealing with registry.

Yuri

Answers (2)

Answers (2)

0 Kudos

Hi Yuri,

R&D has a few more questions for you.

Did you create the report in Visual Studio's CR Designer or using a stand alone version of CR Designer?

So it's still an issue, what was the original file type?

Thanks again

Don

yumb
Explorer
0 Kudos

Convert existing OLE Image objects from "PBrush" type to "Picture (Device Independent Bitmap)"
(Right Click on OLE object -> Bitmap Image Object -> Convert... -> Convert to: Picture (Device Independent Bitmap).

This solved the problem and images are now shown in Windows 11 without re-insert image files.