cancel
Showing results for 
Search instead for 
Did you mean: 

Authentication incorrect! when connecting to SAP S/4HANA Cloud in SAP Business Application Studio

I044433
Product and Topic Expert
Product and Topic Expert
0 Kudos
2,150

Hi,

I am trying to connect SAP S/4HANA Cloud and consume a service in SAP Business Application Studio to build a Fiori List report. However, in the step - Data Source and Service Selection I'm getting error - "Authentication incorrect!".

Here is what I did as pre-steps -

1. Set up communication arrangement

2. Set up destination in SAP Cloud Foundry

3. User/Password: Inbound user and password set up in the communication arrangement

4. Chose the floorplan - List Report object page and getting the following error

5. Here I provided the Inbound communication user and password in the Service username and Service password

Regards

Rohit

bhavya_sri3
Participant
0 Kudos

Hi Rohit Khan,

We are also facing the same issue. It was working fine until few days back(Populated the service catalog list instead of asking for User credentials). It is now asking for authentication, as in your screenshot.

Could you please share the solution if you were able to resolve it.

Thanks in advance!

Thanks,

Bhavya

Accepted Solutions (0)

Answers (6)

Answers (6)

former_member758248
Discoverer
0 Kudos

Hello all,

I'm having a similar Authentication issue with the service password as a Mandatory field.

This are the destination properties and the additional ones that I'm setting up:

But when I try to configure the data source and service, I can't proceed either:

Do you know what could be going wrong?

Thanks in advance!

Florencia.

sauravchetry
Product and Topic Expert
Product and Topic Expert
0 Kudos

No matter what additional properties I choose for the destination set up, there is always a prompt for service user and password when setting up the Fiori freestyle template. This was not the case a few days ago. Tried Destination with both hardcoded credentials as well as "No Authentication", no success. Something changed recently?

I have gone through the SDK github literature. In terminal I get 200 OK for the CURL to the service. When setting this up on the freestyle template there is the user/pasword promt. That does not accept the values.

https://sap.github.io/cloud-sdk/docs/js/guides/bas-external-system/

I044433
Product and Topic Expert
Product and Topic Expert

Hi Saurav,

When you call the service URL while creating the app, your service URL should be something like below. It will work.

For example, if your destination name is - 'saurav', then change the url like below -

From this - https://myxxxxxxxx-api.s4hana.ondemand.com/sap/opu/odata/sap/<service_name>/

To this - https://saurav.dest/sap/opu/odata/sap/<service_name>/

Regards,

Rohit

rcaziraghi
Participant
0 Kudos

Hello all,

I had the same issue and solved it by inserting the correct "sap-client" value in the destination configuration:

Thanks.

Rafael.

vinoth_gru_it
Explorer
0 Kudos

Hi rohit.khan,

I am facing the same issue. Please let me know if you find any solution for this.

Thanks in advance!

Regards,

Vinoth

yuval_morad
Employee
Employee
0 Kudos

Please decide if you access the/4 Cloud catalog with COM 0013,

or access a direct service.

If you use catalog then in the destination set up the odata_abap should be used and the url should include only the host.

If you use direct service then in the destination set up the odata_gen should be used and the url should be the full service url, in addition you should put back the full_url

yuval_morad
Employee
Employee
0 Kudos

Hi

1. Please remove the full_url attribute in case you refer to the host as url and actually consume the service from a catalog

2. Can you check it also in the Fiori freestyle wizard

I044433
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hey Yuval,

Thanks for your reply. Here is the observation -

  1. I removed the full_url
  2. I used free style wizard and it accept the service url e.g. /sap/opu/odata/sap/SERVICE_NAME), but then it errored out. See the screenshot
  3. I want back to try it with the original option - SAP Fiori Elements option, and tried to give the service (inbound) user and password created in the S/4HANA Cloud system under communication arrangement tile, yet stuck at the same - Authentication incorrect! issue.
  4. I glanced through the SAP Help and landed at this page (For deploying to SAP S/4HANA Cloud, you need to set up a destination to an S/4HANA Cloud system with...). I am not sure if this is something we need to do

Appreciate your response.

Regards

Rohit