cancel
Showing results for 
Search instead for 
Did you mean: 

Assertion failed MDG-S Vendor UI

former_member591879
Participant
0 Kudos

Hello,

we are currently configuring the standard MDG-S Vendor UI Create ERP-

Vendor Change Request (VENDR01) and Workflow (WS54300005). Workflow seems to behave as expected with the exception

that everytime when we try to add a Purchasing Organisation including corresponding purchasing data the CR is terminated in the UI with a

dump (adding Purchasing Organisation key field only no dump is happening and WF finishes successfully).

Furthermore, when we change the number assignment configuration to BP External numbering + Vendor external numbering / Same numbers same dump is already happening much earlier when we try to save Vendor Adress Details in the Create

ERP Vendor CR before adding Purchasing Organisation Data or even submitting the CR.

Same dump behaviour with the Lean Vendor CR VENDL1.

Category ABAP Programming Error

Runtime Errors ASSERTION_FAILED

ABAP Program CL_USMD_MODEL=================CP

Application Component CA-MDG-AF

Date and Time 29.01.2013 15:06:22

Short text

The ASSERT condition was violated.

Error analysis

The following checkpoint group was used: "No checkpoint group

specified"

If in the ASSERT statement the addition FIELDS was used, you can

find

the content of the first 8 specified fields in the following

overview:

" (not used) "

" (not used) "

" (not used) "

" (not used) "

" (not used) "

" (not used) "

" (not used) "

" (not used) "

"ASSERTION_FAILED" " "

"CL_USMD_MODEL=================CP"

or "CL_USMD_MODEL=================CM02S"

"DETERMINE_STAGING_PP_SOURCE_P"

Anyone experiencing the same issue ?

Regards,

Michael

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Mike,

I am encountering the same error now. May I know if you were able to resolve this issue by now? If yes, I would appreciate if you can inform me how to resolve this.

Thanks.

Regards,

Riza

former_member188878
Active Contributor
0 Kudos

Hi Mike,

This issue comes any inconsistances in application component in your case "CA-MDG-AF"

Not sure about excat reaso but Please refere to the below threads might help u.

http://scn.sap.com/thread/1921022

http://wiki.sdn.sap.com/wiki/display/BI/Runtime+Error+ASSERTION_FAILED+in+ABAP+Program+CL_RSAWBN_TRE...

regards

shankar

Former Member
0 Kudos

Hi Michael,

I am also working on MDG-S via vendor UI.

It seems that I am facing to the issue that you described

Let me explain when and how my DUMP appear

I have extended my data model and the activate the new data model BP

But now when I try to create a supplier/ erp vendor, I have directly a short dump with the message "ASSERT condition was violated"

Could you explain how you have solved your issue ?

Thanks in advance

Sébastien