cancel
Showing results for 
Search instead for 
Did you mean: 

APD error sql - end truncate table

Former Member
0 Kudos
348

Hi there,

When Executing the APD, I am getting error that

SQL - END

TRUNCATE - TABLE

I thought this is due to some memory issue, so I did uncheck the flag "use internal memory - as part of performance setting - through menue GOTO" ...still I am getting the error.

could someone please help me

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

hi Maven,

I would recommend you to minimize the data to few records and try to load. This will tell you exactly if the issue is with memory or something else. I think it has some improper mapping of fields or wrong data is being loaded. If you have a date, the format of the date is very important.

thanks.

Wond

Answers (1)

Answers (1)

Former Member
0 Kudos

In APD screen right click on each process type to display data and this would tell you which step is causing the error.

Thanks

Krishnan.

Former Member
0 Kudos

Hi ,

when I try to display data at the Query node in APD, its taking time with a message at the bottom "source data is being read and result is being calculated" and then time out. if I execute in background, I see the job log with the SQL END and Truncate table error messages. I really had no clue.

in Dev Environment its working fine. Few minutes back, I tested in dev then transported the Qry and APD to QA. and the APD still failing in QA with same error.

Any help is greatly appreciated

Edited by: curious maven on Aug 29, 2011 7:38 AM

Former Member
0 Kudos

Hi

After spending some more time with this issue, looks like it is trying to delete the temporary table. And it keeps doing that forever.

In a separate session, through the menu "Environment --> clean up temporary Tables" it says, there are no temp tables to delete.

I don't understand why its trying to delete the temp table that long. was it becasue there is no temp table to delete in the first place?

in DB02 I found certain table space called PSAPSR3DB which says 100% used. is it something to do with APD execution/memory or any anything.

Any help is greatly appreciated.

Thanks