Showing results for 
Search instead for 
Did you mean: 

Analytics Apps - Cannot load tile / !CDS_P_P_STARTDATE

0 Kudos

Hi everybody,

after the update from 1709 to 1809, my analytic apps dont work anymore.

Some other Fiori Apps based on SAPUI5 didnt work aswell. There where OData Services missing, that means authorization objects with type IWSG in SAP catalogs. I activated with help from fiori library and stc01 again. For the analytic apps too, but still the tile cannot load.

I get errors in depending of CDS (look picture) and especially to variable "!CDS_P_P_STARTDATE". Maybe here's the problem ?

Could someone please share what I can do to fix that problem. I didnt get it, when I read the other threads of this kind of problem.



Accepted Solutions (0)

Answers (6)

Answers (6)


This may be a cause to your issue:

0 Kudos

Manage to solve this issue with this sapnote.


0 Kudos

Hi Marvin

Did you solve this issue?

I have similar issue now.

I would appreciate if you can share your experience.

Kohta Suzuki

0 Kudos

Hi Kohta Suzuki,

I'm sorry, I couldnt solve this problem last year november and didnt try it again, because I worked on other things.

I hope you can solve it and maybe then you can post a solution.

KR Marvin

Active Contributor
0 Kudos

If the service /SSB/SMART_BUSINESS_RUNTIME_SRV is already active then just ensure that it has the correct system alias assigned.

If it already has the correct system alias, check transaction SU53 on your gateway and backend systems after trying to test the service from the gateway client - 403 forbidden error usually means that your user is missing some of the required authorization(s).

0 Kudos

Hello Marvin,

One of the most simple reason why the KPI is not working is cause of the CDS view not being active.

Here are the steps I would suggest you follow:-

Check the objects in DB02/DBACOCKPIT -> Diagnostics -> Missing Tables and Indexes -> Objects missing in the database -> Views.

Take the full list and always use this complete list, as CDS views are interconnected, you will never be able to get a couple of them activated.

To create the CDS views, run report RUTDDLSACT in t-code SE38/SA38:and give the full list.

Run this report in background as it might time out.

Hope this helps.



0 Kudos

Hello Rishab,

I'm happy for another answer. Thanks.

I follow your steps and check it.

It looks like this:

Under Objects missing in the database, is not a folder views. So like the summary shows, it should be okay.

Apparently optional indexes were just not created.

KR Marvin.

Active Contributor
0 Kudos

Please ensure that the OData service /SSB/SMART_BUSINESS_RUNTIME_SRV is active with the correct system alias that points to the backend S/4HANA system. The Smart Business KPI tiles require this OData service to be active in order to be able to pull data and display in the tiles.

0 Kudos

Thank you for your fast answer.

When I try to activate this OData service,I get a error "Service: /SSB/SMART_BUSINESS_RUNTIME_SRV 1 failed".

When I check in tcode "/IWFND/MAINT_SERVICE" I find a similar or same service already. Soft State Status is "Not Supported".

In the catalog "SAP_PRC_BC_PURCH_ANALYTICS" I find the authorization object with type IWSG "ZSMART_BUSINESS_RUNTIME_SRV_0001".

Do I need the authorization object IWSG "Z/SSB/SMART_BUSINESS _RUNTIME_SRV_001"?

because with type IWSV its "/SSB/SMART_BUSINESS_RUNTIME_SRV_0001"

KR Marvin.

Active Contributor
0 Kudos

Can you verify that for the tiles which are showing cannot load tile error, whether you are able to successfully test the corresponding OData services from the gateway client?

0 Kudos

Thank you for your answer.

I ran for the Purchase Order Value App all OData Services.

When I ran as request-URI "/sap/opu/odata/sap/SMART_BUSINESS_RUNTIME_SRV/" I got as status code 403 Forbidden. For all others OData Services I got 200 OK. I tried to activate it again, but still 403 Forbidden because of error "no namespace found for name "smart_business_runtime_srv".

That system was fully configured in 1709 and I didnt have to set anything like that.

Can you me please explain what are the next steps are ?

KR Marvin