cancel
Showing results for 
Search instead for 
Did you mean: 

Analysis Services not added to Adaptive Processing Server during installation

Former Member
0 Kudos

Hi all,

I'm experiencing some trouble with my installation.  I already added this in another discussion (http://scn.sap.com/docs/DOC-33904)

Based on a link that Tammy forwarded to me, I already discovered what goes wrong during the installation.  Now the trick will be to find a solution...

As stated before, I did a full install on a SAP BI Platform server with SP5 installed.  The BI server is a plain server with a default install on it (Tomcat6 deployment).

Here is my full installation detail:

SAP BO BI 4 SP5

MS SQL Server 2008 Repository

OS: MS 2008 R2

License = 4 CPU license - premium.

Installed on a VMWare machine

The installation is discovered in the Control Panel in the installed programs, but the Analysis Service is not added as a common service to the Adaptive Processing Server.

Is there any one who can help me out with correcting/completing the installation?

I already tried to reinstall from scratch, but no result.

Thanks for your advice.

Kind regards,

Jorn

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Did anyone find a solution to this issue?  We have what appears to be the exact case as Jorn and are working through the details with SAP.  As expected they are suggesting the installation is not complete and we should following the descriptions in several notes.

We have checked all of the notes and they mostly refer to adding the Analysis Service manually if it was not added during the installation.   We have a fairly uncomplicated installation, which mirrors Jorn's environment above, and the installation says it was successfully completed.  Uninstalls and re-installs report the same thing but we still do not see the service and Design Studio client can not connect (suggesting the analysis service is not running).

Any ideas?  We'll continue to work the ticket with SAP the ticket approach for us either helps immediately or it tends to go on for weeks - I'm hoping for a faster response elsewhere.

Thanks,

Adam 

former_member355125
Discoverer
0 Kudos

Hello Adam,

We allso had the exact same problem these last few days. We could not see the Analysis Application Service after installing Design Studio. The strange thing we experienced was that this problem only occured on our production server and not on development and QA.

I did all the installations myself and the cause of the problem turned out to be the fact that I did not have a user profile on the production server. Every time I logged in there was a message stating that I was logged in with a temporary profile. There was no folder for my user present in the users folder.

After an administrator (with an existing profile) installed Design Studio, everything worked perfectly!

The Analysis Application Service was visible.

I hope this may help you.


Best regards,

Ralf

Former Member
0 Kudos

Thanks, Ralf.  We looked at the details and it appears that we have the profile, but the error indicates that the locale in the profile is missing.  We are now running some scripts from SAP to add the analytics node with a specific locale.  I will look further into your suggestion.

SAP suggested we run the addnode.bat in the scripts folder to supply the locale.  When running this we ran into an issue where it is not connecting to the CMS of "BusinessObjects CMS 140".  Our CMS connection is BI4_CMS_DSN.  Looking into this part now.  Any suggestions appreciated.

Adam

Former Member
0 Kudos

Problem solved.  It was directly related to encryption on the server, though it may also be related to the name of the SIA.

1. We added encryption to our servers and the local tmp folder (under the user account installing it) was getting encrypted during the installation.  As a result the copy task from the tmp folder was not finding what it wanted.  it looked like the virus scan was removing the files, but was instead the encryption process updating the files.

2. The secondary possibility was the SIA name.  I say possibility as we updated both at the same time and it is possible that only encryption was causing us an issue.  Our SIA name has "-" (dash) in it.  According to the documentation you should not have underscores, but I do not recall seeing dashes as an issue.  The SIA name for the service read as follows us-server1 and showed up in the error log as "unable to stop SIA ususcoreserver1".  This appears to indicate the dash translates to an underscore in the naming (ie, us+uscore+server1). We took the opportunity to change the SIA (ie, create a new one and delete the original).

After this a simple uninstall and then re-install resulted in the services being added successfully.

Thanks for the inputs.

Adam

ithernfit
Discoverer
0 Kudos

Hi Jorn,

   Did you find a solution for your problem? I'm facing the same situation during the installation.

It ends successfully but no Analysis Application Service is available to add a new server.

Thank you

TammyPowlas
Active Contributor
0 Kudos

Jorn - Just to be sure you are installing SP01, correct?

If no one responds I recommend opening a note with SAP Support.

Everyone, here is the installation video from the SAP Customer Solution Adoption team:

Former Member
0 Kudos

Hi Tammy,

thanks for your answer.

Yes, I'm installing the SP01 onto the server.

I followed 2 different paths to get there:

  • upgrade the main installation with SP01
  • install SP01 directly

both of the installations fail to have the Analysis Service into the Adaptive Processing Server.

So no luck at the moment

All other requirements stated in the document are checked once again and do comply, so I see nothing why it shouldn't work...

Any ideas are appreciated.

Jorn

Former Member
0 Kudos

Hi Jorn,

are you able to create a new Server and add the Analysis Application Service?

Former Member
0 Kudos

Hi Sebastian,

When I create a new server, I cann't add the Analysis Application Service.

There is something going wrong during installation, which is hart to explain to me.  Everything is done as stated in the different documents and movies.

Jorn