cancel
Showing results for 
Search instead for 
Did you mean: 

Analysis 2.2 environment variable SAPLOGON_INI_FILE not working

Former Member
0 Kudos

Hi,

i installed Analysis for Office 2.2. (SP3) on MS Office Professional Plus 2010 and SAP GUI 740 Final Release Build 1635946

We want to use it without BO platform for direct connection to SAP BW systems.

The current problem is as follows:

All SAP BW connections are perfectly available when i put the saplogon.ini in the directory

C:\Users\123456\AppData\Roaming\SAP\Common\saplogon.ini           .

Now the requirement is to change the name of the file and place it in another folder, e.g. like

C:\Users\123456\AppData\Roaming\SAPLOGON\abc.ini

Therefore the Environment variable SAPLOGON_INI_FILE is configured in the following way:

%appdata%\SAPLOGON\abc.ini

Now no SAP systems are shown within Analysis for Office.

It seems like the Environment variable is not working with analyis for Office 2.2.

SAP Bex Analyzer is working just fine with the abc.ini in

Did anyone encounter similar Problem?

Any help is greatly appreciated.

Thanks in advance

Tobias

Accepted Solutions (1)

Accepted Solutions (1)

TammyPowlas
Active Contributor
0 Kudos

It appears this may be fixed in SP2/SP3 of 2.2?  See this note: https://launchpad.support.sap.com/#/notes/2277088/E

Former Member
0 Kudos

At this moment it is somehow working as it should - all connections are shown.

When i now change the environment variable to rubbish, AfO still shows the connections but Analyzer got no connections.

I guess you are right and it is working because of the SP3.

Thanks for your help.

Answers (1)

Answers (1)

reyemsaibot
Active Participant
0 Kudos

Hi,

maybe your SAPLogon has a wrong path?

Maybe you can find the issue here.

BR

Tobias