cancel
Showing results for 
Search instead for 
Did you mean: 

An error occurred: self signed certificate Visual Studio Code

0 Kudos

I am having problems in visual studio Code when generating a fiori application with an Odata service implementing in RAP on Premise


Accepted Solutions (0)

Answers (6)

Answers (6)

quiggs1000
Advisor
Advisor

Hello Cristian,

Can you please try and use the instructions detailed at

https://help.sap.com/viewer/17d50220bcd848aa854c9c182d65b699/Latest/en-US/4b318bede7eb4021a8be385c46...

If the OData service certificate is self signed, these steps will need to be followed.

Thanks,

Ian

vijay_jala2
Explorer
0 Kudos

Hey Ian

I did following the above steps in the link but no success. Please advise.

Regards

Vijay

0 Kudos

Hi Cristian,

Try the following steps, which helped me to resolve similar issue:

  1. Access with browser any OData service metadata document URL on your SAP system and download Root CA certificate. Root certificate is usually the first one in the hierarchy of 3 certificates available there. Certificate file will be downloaded with ".crt" extension by default.

  2. Right-click the CA certificate file and select Install Certificate.

  3. Add Windows Environment variable NODE_EXTRA_CA_CERTS with path to this ".crt" file as well.

  4. Restart Visual Studio Code and try again.

Regards,

Vladimirs

quiggs1000
Advisor
Advisor
0 Kudos

Hi Vijay,

Sorry to hear you are still having problems :(. It may be due to a number of factors.

- Are you using a corporate proxy? If so, can you reach out to your IT support to see if they can support?

- Another option you could potentially do is to disable strict ssl. Please open a terminal in VSCode and type `npm config set strict-ssl false`. Then restart your VSCode environment and see if this has resolved it.

Regards,

Ian

quiggs1000
Advisor
Advisor
0 Kudos

Hi Vijay,

Please post details of the error message you are receiving. Also, let me know if you are using Windows or MacOs?

Thanks,

Ian

vijay_jala2
Explorer
0 Kudos

Hello Ian

Below is the error message that I am getting and I am using Window. Please advise.

sdebeaulieu
Participant
0 Kudos

Hi,

For information, when you install certificate in your Windows Store, you need to select the good folder. In my case it was "Third-Party Root Certification" (in french "Autorités de certification racine tierce partie").

Thanks Ian for the link.

Cheers,

0 Kudos
vijay_jala2
Explorer
0 Kudos

Hey Cristian

Did this issue got resolved for you? If so please share the resolution. I am also facing the same issue.

Regards

Vijay