Showing results for 
Search instead for 
Did you mean: 

Ambigous functionality of Delta DTP

Former Member
0 Kudos

Hello Guys,

I have a situation,

Till now I had BI 3.X flow and used to load data through the same, but now I have converted the flow to 7.0 and usied DTP for loading.

The main problem is I have kept the same data Target for the new flow, PSA --> DSO --> Infocube.

There is data in all targets and I DONT want to delete data in the targets.

When I ran delta DTP from PSA to DSO it worked fine and it brought records keeping in mind the last delta through 3.X flow.

but the problem occured when loading Infocube from DSO.

Its not bringing records correctly, as it is delta it should bring only those records which are changed and not all, but Delta DTP is bringing all the records in DSO.

Can anyone throw some light on this as it is very criticle and I am stuck due to this as it is FI-GL cube and I cand afford to load whole data again as it is more than 100 million records.

any help would be greatly appreciated.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Saurabh,

For the very first time delta dtp will load all the data and from second extraction onward keeping the first extraction as delta pointer it will fetch only new data.

So what you need to do is, if you don't want to extract all the data for first time then simply execute DTP without data transfer and then load new data and run delta DTP.



Active Contributor
0 Kudos

Hi Saurabh

I believe when you ran the Delta DTP from PSA --->DSO , old PSA requests had Data Mart Status green. So, DTP did not consider those request for further loading.

But the DTP between DSO --->Cube has to depend on RSMDATASTATE table to identify DataMart status between DSO and Cube. As in this case no entry exists previously for this source-target combination, DTP is fetching all the records.

What you can do here...

1. Delete the newly loaded request/requests from DSO

2. Go the Delta DTP--->Execute -

>Processing Mode -

> select * No Data Transfer; Delta Status in Source: Fetched *

Now you have Delta pointer set in RSMDATASTATE for DSO-Cube.

3. Load new requests from PSA to DSO via Delta DTP

4. Run Delta DTP from DSO to Cube ( it should fetch only the new records)



Former Member
0 Kudos

I concur with Anindya Bose

Former Member
0 Kudos


Have you tried with option get new data request by request in dtp.

You will get this option under delta, check this once.

If it doesn't work, we can delta dtp without data transfer.

You wil find this option in execution tab of dtp.