cancel
Showing results for 
Search instead for 
Did you mean: 

Allow Custom Values (Parameters with DropDown Box)

Former Member
0 Kudos

Post Author: sher

CA Forum: General

Can someone tell me why am I pulling 1 value of approximately 15 when setting up a DropDown parameter instead of listing all of the values? In field explorer--parameter (right click to edit parameter), under "list of values", I chose 'static', under "value field" I chose the appropriate field from the table, under "actions", I chose 'append all database values". Instead of reviewing all 15 values, only the first value is displayed. I would press the "clear or delete" button (to clear the default value) and the one value goes away but appears again when I click "append all values". The "Allow Custom Values" is set to true and I can't change it when I click "append all database values". It seems as though this field has a build-in default value that won't change. I have deleted and renamed the parameter but it does the same things. This is why I assumed that the default was attached to that field. When I go to "select expert" and select my field for the dropDown box, then select browse, I see all 15 values. Strange!!!

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Post Author: paulcoates@hotmail.com

CA Forum: General

There is a registry setting on your local pc and there is also a setting in Infoview that could be restricting your returning list

Former Member
0 Kudos

Post Author: ygregersen

CA Forum: General

I believe you need the parameter to be a dynamic prompt. When you choose Static it asked you to go look at the field and choose the first one as like a default.