cancel
Showing results for 
Search instead for 
Did you mean: 

AJAX Frameworkpage application parameters are not working

stuerzea
Explorer
0 Kudos

Hi experts,

since we are using the AJAX Frameworkpage, URL application parameters for transaction iViews are not passed to transaction any more (Portal version is 7.31).

For example we are calling transaction VA03 via htmlGUI and the following link:

https://our-domain:our-port/irj/portal?NavigationTarget=ROLES://portal_content/domain.fmg_fmgcontent...

But VBELN parameter gets not filled any more.

If I call the portal with default frameworkpage everything is working fine.

Thanks in advance for your help!

Regards,

Andreas

Accepted Solutions (1)

Accepted Solutions (1)

stuerzea
Explorer
0 Kudos

We applied the above suggested note 2021994 - "Malfunctioning of Portal due to omission of post parameters" via SP Upgrade to 7.31 SP17 but the problem remains unsolved.

Any other ideas?

BR,

Andreas

nickrankin
Contributor
0 Kudos

Hi Andreas,

Try changing the URL parameters to the encoded version, e.g:

ApplicationParameter=VBAK%2DVBELN%3D30030307

Let me know if this sorts it.

Best regards,

Nick

Answers (2)

Answers (2)

saar_dagan
Employee
Employee
0 Kudos

Did it work for you?

BR,

Saar

stuerzea
Explorer
0 Kudos

Hi Saar,

our basis team is currently implementing the note you mentioned.

I will come back with an update if system-patch is done.

BR,

Andreas

saar_dagan
Employee
Employee
0 Kudos

Hi Andreas,

This sounds exactly like note:

2021994 - Malfunctioning of Portal due to omission of post parameters


Please check it out.

BR,

Saar