cancel
Showing results for 
Search instead for 
Did you mean: 

aii_af_jmsproviderlib.sda deployment error

Former Member
0 Kudos
69

Hello all,

I am trying to install External Drivers for JMS Adapters in the Adapter Framework of Exchange Infrastructure XI-3.0.

For that I am following the "How To Install and Configure External Drivers for JDBC & JMS Adapters" document.

When I try to deploy the .sda file that I have created , I am getting the following error message.

Summary:

========

There were 1 archives selected.

0 archives successfully loaded.

Loading of 1 archives failed.

Details:

========

1) Error loading archive

C:\aii_af_jmsproviderlib.sda

(server side name is: C:\aii_af_jmsproviderlib.sda)

com.sap.sdm.util.sduread.IllFormattedSduFileException: The information about the development component

found in the SDA C:\aii_af_jmsproviderlib.sda is either missing or incomplete!

Manifest attributes are missing or have badly formatted value:

attribute keylocation is missing

attribute keyname is missing

attribute keyvendor is missing

attribute keycounter is missing

-


Can any one tell what could be the problem?

Regards,

Amith

Accepted Solutions (1)

Accepted Solutions (1)

former_member91687
Active Contributor
0 Kudos

Hi Amith,

Have you done all the steps given in the pdf document prior to the deployment step? Are you able to choose the your sda file for deployment?

Regards,

Chandra

Former Member
0 Kudos

Hi Chandra,

I have done all the steps in the pdf document. And I am able to choose my .sda file for deployment. But the result is as described above.

Regards,

Amith

Former Member
0 Kudos

Hi,

First, double-check your XML files in the SDA file. All XML files must have the path of "meta-inf\", except provider.xml, which must have the path of "server\".

Then, during deployment, you must change the "Deployment Configuration" to use any version. This change can only be done right before or after you add the SDA. Once you click "Next", this can no longer be changed.

Regards,

Bill

Answers (2)

Answers (2)

former_member91687
Active Contributor
0 Kudos

Hi Amith,

This thread talks about a similar problem, try adding all the jar files and zip the sda file again.Look at the note mentioned in the thread.

Regards,

Chandra

Former Member
0 Kudos

Hi Chandra,

Now I am not getting error. But in #Dependencies column it is showing 0 instead of 1. There are no "Update deployed SDA\SCA’s that have any version” radio button". radio button to choose also(That screen itself is not coming).

Any help?

Regards

Amith

Former Member
0 Kudos

My guess is that you have created the zip file wrong, so the new file structure does not match the orginal.

/daniel

Former Member
0 Kudos

Dear Daniel,

Can you be more specific?

Thanks n Regards,

Amith