cancel
Showing results for 
Search instead for 
Did you mean: 

Aggregator is not starting

Former Member
0 Kudos

Hello,

I have installed patch 36 on our portal and the portal activity reporter is not starting.

I recieve this message when I try to start the aggregator.bat:

-


BEGIN AGGREGATOR

-


try to load sql.properties

java.io.FileNotFoundException: sql.properties (The system cannot find the file s

pecified)

at java.io.FileInputStream.open(Native Method)

at java.io.FileInputStream.<init>(FileInputStream.java:91)

at java.io.FileInputStream.<init>(FileInputStream.java:54)

at com.sap.portal.webreport.tools.util.DBWriter.<init>(DBWriter.java:56)

at com.sap.portal.webreport.tools.Aggregator.<init>(Aggregator.java:34)

at com.sap.portal.webreport.tools.Aggregator.main(Aggregator.java:50)

exception during instantiating Aggregator

java.sql.SQLException: The url cannot be null

at java.sql.DriverManager.getConnection(DriverManager.java:489)

at java.sql.DriverManager.getConnection(DriverManager.java:172)

at com.sap.portal.webreport.tools.util.DBWriter.connect(DBWriter.java:14

0)

at com.sap.portal.webreport.tools.util.DBWriter.<init>(DBWriter.java:66)

at com.sap.portal.webreport.tools.Aggregator.<init>(Aggregator.java:34)

at com.sap.portal.webreport.tools.Aggregator.main(Aggregator.java:50)

I have checked everthing now and also reinstall the portal activity reporter. But no luck so far.

Thanks

Olaf

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Olaf,

Is your DB_Connection.properties configured? Also, did you try to restart it?

James

Former Member
0 Kudos

Hello James,

my db_connections.properties has the right values.

I tried serveral restarts!

Thanks

Olaf

Former Member
0 Kudos

Olaf,

I would double check, as stated on link below.

http://help.sap.com/saphelp_nw04/helpdata/en/98/74362ae5fc48caaf690d0b7ed143f2/frameset.htm

If this is your first time on the swim lane with Activity Reporting, you can check the technical presentation on

https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/85303750-0501-0010-0199-944...

It is detailed, and comprehensive with both unix/windows.

James

Former Member
0 Kudos

Hi James,

the aggregator was runing befor installing patch 36! So I didn't change the db properties!!! The properties are right! Sorry!

Thanks

Olaf

Former Member
0 Kudos

Hi James,

the aggregator was runing befor installing patch 36! So I didn't change the db properties!!! The properties are right! Sorry!

Thanks

Olaf

Former Member
0 Kudos

Hi James,

the aggregator was runing befor installing patch 36! So I didn't change the db properties!!! The properties are right! Sorry!

Thanks

Olaf

Former Member
0 Kudos

Hi James,

the aggregator was runing befor installing patch 36! So I didn't change the db properties!!! The properties are right! Sorry!

Thanks

Olaf

Former Member
0 Kudos

Hi James,

the aggregator was runing befor installing patch 36! So I didn't change the db properties!!! The properties are right! Sorry!

Thanks

Olaf

Former Member
0 Kudos

Olaf,

You see any indications on your default.trc file?

James

Former Member
0 Kudos

Hi James,

I'm sorry I don't have a default.trc file. The aggregator is tool for 6.20!!! But there is nothing in the console logs as well.

With 6.40, where you default.trc files, there is a build-in solution for this. You just have to create an iView.

Olaf

Former Member
0 Kudos

Olaf,

The log files are created in the file system under the path: <SAPJ2EE Engine folder>\ cluster\server\log\

Does your agg.bat file have the correct J2EE home locations?

http://help.sap.com/saphelp_nw04/helpdata/en/13/20a21d8f6048e8908611539aed131c/frameset.htm

James

Former Member
0 Kudos

Hi James

I have portal runing on WebAS 6.20 Patch 36!!!

Your answer is for 6.40!

Olaf

Former Member
0 Kudos

Olaf,

Kindly read SAP note 657765

How to turn on j2ee engine http tracing capability for 6.20

James