cancel
Showing results for 
Search instead for 
Did you mean: 

AGGREGATION PROBELM..in BEX

Former Member
0 Kudos

Hi All,

I have PO items under Pur doc. No in cube.

In Cube:

Contarct Pur doc. No Pur doc.Item ZCum.Pln.Val

100 50000 10 40k

100 50000 20 40k

100 50000 30 40k

100 50001 10 40k

100 50002 10 40k

100 50002 20 40k

In Report I want to see : (over all picture i.e Client needs without Po items & Doc_numbers)

100 50000 40k

100 50001 40k

100 50002 40k

But it shows NOW :

100 50000 120k ( It is summed up , WRONG VALUE)

100 50001 40k (Right value)

100 50002 80k ( It is summed up , WRONG VALUE)

In RSA1 --> Zcum.pln.val Key Figure info object’s AGGREGATE Tab properties are:

Aggregation : SUM

Exception Aggregation: Summation.

Cummulative value option is also selected.

1. What changes shall I do, to get my required result in RSA1- infoobject properties.? Pls. advise step wise.

2. If I change properties to this Zcum.pln.val object , Will it effects to existing Cube data?

3. without changing properties to this Zcum.pln.val object, what options shall I use in BEx level, to get required result.

Please help me and tell step wise.

Thanks & Regards,

siri

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi,

try this -

right click Zcum.pln.val in BEx & choose contant selection.

or

choose claculate result as First value.

hope it helps

regards

VC

Former Member
0 Kudos

HI VC,

I tried but still showing wrong values.

Any other ideas.

THNX,

Sri.

Former Member
0 Kudos

Hi Sri,

I tried it & it works -

right click on Key Figure (planned value) & choose calculate result as first value.

All other setting either default or not defined. ( Don't think Constant selection).

hope it helps

VC

nikhil_chowdhary2
Contributor
0 Kudos

Instead of changing the infoobject, in the query, right click on properties for Zcum.pln.val, change Calculate result as - Suppress results.

I hope this solves the problem.