cancel
Showing results for 
Search instead for 
Did you mean: 

Agent Version Differs From LMService

0 Kudos

HELLO SAP community,

I have yet another situation which requires the expertise of users with more knowledge than I posses. I am in the process of setting up a new Solution Manager 7.1 system. We run SAP on two kinds of servers, AS400 and Windows. My current task is to set up Diagnostics Agent 7.3 on all the hosts we run an SAP system on. I finished installing Diagnostics Agents on my AS400 systems but I have run into something while working with one of our Windows systems.

When I set up the diagnostics agent I made sure to include all the info about the sld I wanted the system to be connected to.

I noticed something was wrong first when I went to do the Managed System Configuration through solman_setup. We have two SAP systems on the host uksapmiiprd, an abap system and a java system. I started out with the config of the the abap system. Once I got to the step Assign Diagnostics Agent I realized something must be wrong with the agent I installed on this host. In the Agent Assignment tab, when I choose Assign, there are no agents on this host to choose from.

I continued to the next tab on this page, SLD Agent Candidates, I see that connection to uksapmiiprd has failed... Makes sense then why the previous tab seems to think there aren't any Diagnostics Agents on this host.

Crazy think is that when I select uksapmiiprd and try to connect it, the pending symbol will be on screen for a little but, but it goes back to connection failure with in several minutes.

I also took a look at the Agent Administration tool. This screen shot is from the agent administration tool. As you can see I am getting the message "Agent Version Differs from LMService" and further right you can see I am getting a status of deploying applications. Under the application management tab, if I try to deploy applications to the agent on uksapmiiprd I get a bunch of errors about how the host can't be found. Under the application viewer tab I can see there are only 6 applications associated with the agent on host uksapmiiprd, but agents on all the other hosts have like 36 applications.

Since I realized something was wrong with this particular diagnostics agent I started researching but didn't find a whole lot to go on. I am a novice at best when it comes to SAP as a whole so I have little idea where to look for the answers. I read a suggestion to look at the diagnostics agent troubleshooting guide, but I just didn't see a fix. So I guess what I would like is some help figuring out why this diagnostics agent isn't connecting to the solution manager correctly, or maybe an explanation as to why the Agent version differs from LMService. Which seems strange to me since I have this same version of Diagnostics Agent on another Windows host and there aren't any messages about the agent version differing from the LMService. Please direct me to any logs I should be looking for, or any documentation that exists which would assist me. If I can not resolve this within the next few days I will probably just try to reinstall the Diagnostics Agent, but I would prefer to just fix the one I have. Thanks for all the help in advance.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Kristen

I hope you solved your problem in the meantime....

As this post seems to be the only one with the keywords "agent version differs from LM Service" I post my solution to this error here:

Symptoms

1. Agent version differs from LMService

2. LogViewer (during agent start): unable to read file smdagent.properties, file is locked

Solution: remove file /usr/sap/DAA/SMDA97/SMDAgent/smdagent.properties_lock (I don't know why it was there, change date: 4 months old)

Result: Agent gets updated

Hope it helps others....

BR

Michael

0 Kudos

Hello Michael,

Thanks for your response. We have since begun a fresh installation of the solution manager and have scraped this one. I will keep your suggestions in mind though if I encounter this issue again.

Thanks,

Kristen

madasamy_arunachalam
Active Participant
0 Kudos

Hi  Kristen

I am updating it though it is old thread, so this will be useful if someone come across similar issue.

From SMD Admin page, when it says "Agent version differs from LMService", just wait for few mins. and Managed System's SMDAgent binary gets automatically synced from Managing System (Sol Man) & then status can be seen as active/in Green.

I didn't see any .lock file for smdagent.properties and also SAP has OSS note 1931100 - "Agent version differs from LMService" Error in Solution Manager 7.1 Agent Administration ...and both of this not applied/applicable  in my case.

regards

Swami

former_member118647
Active Participant
0 Kudos

Thanks Michael for the solution. it worked for me

Answers (1)

Answers (1)

heiko_burkhardt3
Discoverer
0 Kudos

Hello,

taking the chance replying to this old thread also. I had the same issue, and in my case the solman j2ee dispatcher threads have been exhaused. I increased the default value 200 to 300 in configuration tool at

"Global Dispatcher Configuration" -> "Managers" -> "Thread Manager" -> MaxThreadCount.

restarted the j2ee instances and all was fine then. After all, the j2ee engine was not able to update the remote system due to lack of j2ee threads.

So this is another solution for this symptom.

Kind Regards,

Heiko