Showing results for 
Search instead for 
Did you mean: 

ADT project login KeePass auto-type but nothing typed (although entry is found)

Active Contributor

Hi, I've got a new laptop with Windows 11, and I can't make the KeePass auto-type feature work with ADT project login, to type automatically the password via keyboard shortcut. I used to know this feature by reading this blog post: Using KeePass to logon to a ABAP Project in ABAP i... - SAP Community.

The KeePass auto-type feature works well for all non-ADT applications, like SAP GUI, Edge, etc.

The software versions I use are: Windows 11, Eclipse 2024-03, ADT 3.42.0, KeePass 2.56.

It used to work well on my previous laptop with Windows 10, Eclipse 2023-12, its corresponding ADT version, KeePass 2.x.

Steps to reproduce: I log in a system and the popup appears:


I press my keyboard shortcut to trigger KeePass which shows the adequate KeePass entries (Ctrl+Alt+K) corresponding to the window title ("Logon for Project <SID>_<client>_<user>_<language>").


I select one entry but KeePass is unable to type the password, nothing happens.

Any idea?

Thank  you.



NB: I suspect that a half-reason (*) is the ADT project login popup ("Logon for Project ...") doesn't appear like a Windows application, i.e. I don't see the ADT project login popup as a distinct application if I press Alt-Tab, but I don't remember if there was a distinct window with my previous laptop:


(*) Half-reason because KeePass is able to recognize the popup and its title because it proposes the corresponding entries.

NB: for information, below are the KeePass options used (I tried many combinations in Auto-Type sending but no luck)


EDIT June 14th, 2024: for information, not related to Eclipse, I just saw that if I start SAP GUI for Windows via "Run as administrator" (so, not using Eclipse), the auto-type which was working when started normally, does not work anymore.

View Entire Topic
Active Contributor
0 Kudos

Today, the solution posted 2 days ago (uninstalling the ZIP files in C:\Users\... instead of C:\Program Files\...) doesn't solve anymore.

But I could make it work by running KeePass via "Run as Administrator", which I can do implicitly as follows:

  1. Properties > Shortcut > Advanced:
  2. Select "Run as administrator"