cancel
Showing results for 
Search instead for 
Did you mean: 

ADT project login KeePass auto-type but nothing typed (although entry is found)

Sandra_Rossi
Active Contributor
326

Hi, I've got a new laptop with Windows 11, and I can't make the KeePass auto-type feature work with ADT project login, to type automatically the password via keyboard shortcut. I used to know this feature by reading this blog post: Using KeePass to logon to a ABAP Project in ABAP i... - SAP Community.

The KeePass auto-type feature works well for all non-ADT applications, like SAP GUI, Edge, etc.

The software versions I use are: Windows 11, Eclipse 2024-03, ADT 3.42.0, KeePass 2.56.

It used to work well on my previous laptop with Windows 10, Eclipse 2023-12, its corresponding ADT version, KeePass 2.x.

Steps to reproduce: I log in a system and the popup appears:

Sandra_Rossi_0-1716969232131.png

I press my keyboard shortcut to trigger KeePass which shows the adequate KeePass entries (Ctrl+Alt+K) corresponding to the window title ("Logon for Project <SID>_<client>_<user>_<language>").

Sandra_Rossi_1-1716969635147.png

I select one entry but KeePass is unable to type the password, nothing happens.

Any idea?

Thank  you.

Sandra

 

NB: I suspect that a half-reason (*) is the ADT project login popup ("Logon for Project ...") doesn't appear like a Windows application, i.e. I don't see the ADT project login popup as a distinct application if I press Alt-Tab, but I don't remember if there was a distinct window with my previous laptop:

Sandra_Rossi_2-1716970049092.png

(*) Half-reason because KeePass is able to recognize the popup and its title because it proposes the corresponding entries.

NB: for information, below are the KeePass options used (I tried many combinations in Auto-Type sending but no luck)

Sandra_Rossi_3-1716970723791.png

EDIT June 14th, 2024: for information, not related to Eclipse, I just saw that if I start SAP GUI for Windows via "Run as administrator" (so, not using Eclipse), the auto-type which was working when started normally, does not work anymore.

View Entire Topic
Sandra_Rossi
Active Contributor

Solved by unzipping the Eclipse files (eclipse-java-2024-03-R-win32-x86_64.zip) to my C:\Users\<myuser>\anywhere folder, which doesn't ask administrator permissions.

I realize that in my previous installation, I had unzipped in C:\Program Files, which displayed a popup "Access Denied" and I clicked "Continue" (administrator permissions):

Sandra_Rossi_0-1718442917353.png

I guess that when starting Eclipse from "Program Files", it's like using "Run as administrator", which is a problem to KeePass if it's not running "with the same or higher rights" (NB: as I said in the Edit of my question, if I start SAP GUI with "Run as Administrator", KeePass doesn't work, because I installed/run KeePass with the normal rights).

Auto-Type - Requirements and Limitations - KeePass:

  • "Rights:
    For auto-type to work, KeePass must be running with the same or higher rights as the target application. Especially, if the target application is running with administrative rights, KeePass must be running with administrative rights, too. For details, see Windows Integrity Mechanism Design. An example are certain instances of VMware Workstation that run on a higher integrity level."