cancel
Showing results for 
Search instead for 
Did you mean: 

ADSO fields getting empty post data activation

aalbis
Explorer
0 Kudos

Dear SAP experts,

Recently I have converted a "Data Mart ADSO" to "Standard ADSO with Write Change Log".

In DEV environment everything looked fine.

- data was activating correct

- fields were populated correct

Once I moved the changes to QA, some fields which were fine in DEV, are getting empty once I activate the data. What could be the reason? I have no start/end/field routine for these fields. It's just 1:1 mapping from datasource -> staging adso -> integrated layer adso.

Additionally, I tried to reproduce the issue in DEV by copying the same ADSO to a new test one and trying to do the conversions on the test one: Data Mart - Standard and reverse, the issue is same like in QA. Only for the old ADSO everything works fine in DEV.

What could cause this issue? Please advise, I need urgent help 😞

Ideally I would like to apply a fix to the old ADSO (not the test one) so everything will work fine in QA for it and no fields would get empty post data activation.

Please help!

MKreitlein
Active Contributor
0 Kudos
Hello @aalbis. It would be interesting to see your key fields in the newly converted ADSO! I would say it is maybe the problem that you don't have enough key fields now and that some records with initial values overwrite others with characteristics available?!
View Entire Topic
aalbis
Explorer
0 Kudos

Greetings @MKreitlein

As keys in the converted ADSO I am using the same ones as the extractor (which is a standard CDS View) -> IFIGLACCTLIR.

1. Source Ledger

2. Company Code

3. Fiscal Year

4. Fiscal Year Variant (added automatically when adding Fiscal Year, as it is compounded)

5. Accounting Document

6. Accounting Document Line item

I simply cannot understand why some random fields like 0FI_DBCRIND, 0SEGMENT, 0FISCPER, 0FISCPER3, which are 1:1 mapped from source to integrated layer, get blank POST data activation. Until the inbound table they are fine. Once the data gets activated, they are blank. Even in the change log they appear as blank.

I have no specific logic applied to these fields, such as lookups, end/start/field routines or formulas.

I have tried the following:

- reload the data;

- activate the adso again using RSDG_ADSO_ACTIVATE program

- create the column view again usin RSDDB_LOGINDEX_CREATE

Will SAP support on this issue in case we open a ticket?

Many thanks to anyone who can provide a tips or any idea regarding this matter!

roland_szajko
Product and Topic Expert
Product and Topic Expert
0 Kudos

I would suggest to first really check the KBA that was provided by @MKreitlein. Also ensure, that before and after image pairs of the same key are processed within the same package. Otherwise it can happen that the before image is processed on it's own, which leads to the initialization of data fields.

Also check: