Showing results for 
Search instead for 
Did you mean: 

ADS: com.adobe.ProcessingException: com.adobe.Processin(200101)

Former Member
0 Kudos

Hi Friends,

I am facing a strange problem.

In my system adobe forms are configured. But when I executed my form after creation from SFP, i am getting the following error:

"ADS: com.adobe.ProcessingException: com.adobe.Processin(200101)".

But when I executed the FP_TEST_00 form from FP_TEST_00 program in SE38. Its generating the PDF properly and FP_PDF_TEST_00 program giving version number too.

Sometimes ADS_AGENT user is getting locked too.

Please help me in sovling this problem.



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos


Check the ADS configuration specified in,

You need to check all the configuration steps to makesure everything is setup right. Also, try after restarting your Java engine where ADS is installed.

Check your ADS RFC connection using SM59 tcode, and check whether ADSUSER and ADS_AGENT are not locked.



Answers (6)

Answers (6)

Former Member

I have faced this problem and solved it.

Does your adobe form have a checkbox ?
In my case, this is caused by a checkbox object in forms.

I created a checkbox without setting On Value and Off Value,
so they have default values On Value; 1 , Off Value; 0.

But the binded value with the checkbox had 'X',
so this error was raised .

I changed On Value to 'X' and Off Value to space,
this error was solved. 

I hope I can be of any help to you.

Best regards,
Kenta JPN


We have a situation where code changes to production cause this same error. To correct it we have to regenerate the Adobe forms by executing the "FP_GENERATE_FUNCTION_MODULE" function module, finding the form, and executing. That may help someone else out there searching for this error.

Former Member
0 Kudos

I got this error because of Adobe form hyphenate -feature. When printing "working" form some text seem to be missing completely and other non-working form just gave this error "ADS: com.adobe.ProcessingException: com.adobe.Processin(200101)".

I tried to print text which was 388 characters long but with text that was 520 chars long didn't have this problem. I even removed all special characters from the shorter text but still it was dumping. When I removed hyphenating completely everything worked perfectly

br, Susan

Former Member
0 Kudos


Kindly check the binding again.

If you have multiple subform, change presence as invisible and test it.



Former Member
0 Kudos

Any solution here.. I have exactly the same issue

Active Contributor
0 Kudos

Can you specify changes from the last working version of the form?

I guess you have something wrong in your binding but forms are sometimes difficult to debug.

You´d better check what elements you´ve added to your form since the last proper version and check its binding.

Hope this will help, Otto