cancel
Showing results for 
Search instead for 
Did you mean: 

adding fields to 2lis_o2_itm

Former Member
0 Kudos

Hello,

I'm tring to enhance the extractor 2lis_o2_itm.

I did the following steps:

1. I added the new field to the structure MCEKPOUSR using the append structure.

2. I used the user exit EXIT_SAPLRSAP_001 to fill the new field.

3. from LBWE i chose the new fields and activated the extractor.

The problem is that i cant find\see the new field i enterd in RSA3 or in trans structure (at the bw side after i replicated DS...).

I checked the table TMCEXCFS and found the new field with blank status (its nor activ....)

Please advise.

David

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

hi,

have you remove the mark on column 'hidden' for that new fields ? rsa6 -> maintain datasource. after remove the mark, save datasource and replicate from bw again.

hope this helps.

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi David,

If you are not able to see the added field to

extract structure in RSA3 , go to Settings->Layout->Current. In the right hand side u will see Hidden fields. Drag and drop your field from right hand side to left hand side . It will appear in RSA3.

Regards,

Prakash

Former Member
0 Kudos

David,

please check the table roosfield for the datasource. Look at the new added fields and check the content of field 'selection'. It doesn't have to be 'A'.

regards

Siggi

Former Member
0 Kudos

Hi Siggi,

I'm not sure i understand your answer.

Can you please be more specific.

Thanks,

David

Former Member
0 Kudos

Hi David,

Where exactly u not able to see the fields in RSA3. In selection screen or in datasource itself...?

If you want to see in selection screen, you have to remove the hide check mark in extractor(where u added the fields), by default system check checkmark for added fields. Once you removed the hide, check the check box for selection, now you can see in the selection tab in info package and in rsa3.

Srini