cancel
Showing results for 
Search instead for 
Did you mean: 

Adapter Engine Missing from Configuration: Integration Bldr

Former Member
0 Kudos

We are using central SLD for the XI servers.

Prior to this, we have already applied and check the configuration

according the the notes

939592 PI Usage Configuration versus Central SLD

768148 Using a separate SLD for XI

720717 Reduce the number of System Landscape Directories (SLD)

and found that the setting and configuration were consistent with the notes. Nevertheless, we double

check it again to ensure that the configuration are consistent. After check and reperforming the refresh for Technical systems, the adapter is still missing from the configuration .

We have also remove the technical systems from the SLD and re-register

the configuration by restarting and redeploying the adapters from VA,

performed cache refresh (http://calypso:50600/CPACache/refresh?

mode=full) on the XI server, SLD data supplier role assignment and trigger data

transfers.

With all these steps executed, we are still not getting the adapter on

the configuration. We noticed:

(1) Domain for Integration points to the central SLD, the name should be "Domain

mercury" with the name as "is.00.mercury". Instead there is a "domain null" which points

to the central SLD with its name "mercury" which is clearly an error. We tried to register the SLD many times but it is still the same. Note that we have applied the note 1117249 and 764176 but the same error still persist.

(2) The adapter engines (com.sap.aii.af) should be in calypso (XI server), and the adapter should not found in the central SLD host. The message below shows on the Cache Connectivity Test on RWB. The error message shows:

Unable to contact Adapter Engine "af.dpi.calypso" that is affected by the data changes

http connection to "http://mercury:50000/CPACache/invalidate" returns the status code "404" in response

The same test ("http://mercury:50000/AdapterFramework/rtc") is done on the calypso (XI Server) shows that the adapter is working there. This is because the adapter franework component is found in the XI server but not on the central SLD.

Question: Where should the adapter be located? in the XI server or the central SLD? From this configuration and setting, the component for the adapter should also be present in central SLD, but this is not the case as shown in the attached screenshot.

Should the adapter framework be deplyed to the central SLD? or there should be a data transfer from XI to SLD for XI adapter framework?

Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos

Hi Tang Sea Nguan,

do you solve the problem Domain null?

thanks for your time

Lionel

Former Member
0 Kudos

Dear Lio,

the problem is too easy to resolve, you are sure a little confiuse, letme teach you:

so, put the following parameters in exchangeProfile like this:

Host PAS (or CI)..........................................................Host SCS

connection.integration.r3.mshost............................... connnection.directory.mshost

connection.integration.sld.name (is.sysnr.host)..............connnection.repository.mshost

connection.rwb.r3.mshost

rwb.server.centralmonitoring.r3.mshost

former_member187563
Contributor
0 Kudos

hi,

you can refer to this blog:

regards,

ujjwal kumar

abhijitbolakhe
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi

Have you imported XI basis content in ID?

without this we can't see adapters

Abhijit

Former Member
0 Kudos

Hi Abhijit

Thanks for the answer, but I am pretty new to this XI thingy, where can we download or find this XI basis content?

abhijitbolakhe
Product and Topic Expert
Product and Topic Expert
0 Kudos

download it from service marketplace...ask your basis guy..

SAPBASIS16_0-20000888.ZIP is the latest XI CONTENT of basis.

This contains a .tpz file.....import this file in ID..

Abhijit