cancel
Showing results forย 
Search instead forย 
Did you mean:ย 

Adaptation Project Generator for VS Code - Adaptation Editor can not be opened

uifivvy
Participant
0 Kudos

Hello experts,

I have tried out the new Adaptation Project Generator for Visual Studio Code an managed to generate an adaptation project for the application "Purchase Order" (F0348A).

But when I try to open the adaptation editor, an error is displayed:

jbarth_0-1709028263871.png

Should the adaptation-editor.html be located in the webapp folder? Because this is not the case for my generated adaptation app.

 

Thanks in advance ๐Ÿ™‚

Julia

 

0 Kudos
Hi Julia, could you please
View Entire Topic
0 Kudos

Hi Julia,

could you please add "debug: true" in your ui5.yaml. It should look like this:

- name: fiori-tools-preview 
  afterMiddleware: compression 
  configuration: 
   component: myapp 
   ui5Theme: sap_horizon 
   debug: true

afterwards please try to start the adaption editor again.

The file adaptation-editor.html is generated at runtime, so it does not need to be part of the webapp folder. The error code that you are getting indicates and issue with the backend

 

 

uifivvy
Participant
0 Kudos

Thank you for your comment, I tried to add the debug option, but it failed with the same error code. Do you know how we can detect the issue with the backend?

0 Kudos
Hi, what kind of backend do you have? What is the default authentication type of your backend?
uifivvy
Participant
0 Kudos
The system is a S4HANA On Premise 2023 and we use basic authentication with user and password.
0 Kudos
Did you created the project in VSCode? If yes, is the system stored in VSCode? Are you getting asked for credentials when you try to start the adaptation editor?
uifivvy
Participant
0 Kudos
Yes, I created the project in VS Code and I've stored the system there. It can be found under "SAP System Details", I've provided my credentials for the system there. If I test the connection, I get two messages: "V2 catalog call returned 149 services" and "V4 catalog service not available". I don't get asked for my credentials when I start the adaption editor.