cancel
Showing results for 
Search instead for 
Did you mean: 

activex viewer on win2008 R2

Former Member
0 Kudos

hi

i'm using cr XI R2 sp6, and my application worked fine on xp/2003/2008, until win2008 R2 IIS 7.5 came along.

when trying to view a report through the activex viewer, a blank screen appears,with no error message.

exporting to pdf, etc.. does work.

are you aware of such a problem ? is there a solution?

thanks

ron

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Ron,

I am getting same results on Windows Server 2008 R2 using Crystal XI R2 viewer and classic ASP application. It worked fine on other platforms till Windows Server 2008 (x32 & x64 bit). But a simple report came up fine.

For this issue, on Windows Server 2003 environment we used to remove the http compression (Dynamic) to resolve this issue. I applied same settings here, but not able to display those reports in the viewer.

Still searching for any available solutions.

Amit.

former_member183750
Active Contributor
0 Kudos

Please see my blog [Report Designer Component (RDC) in classic ASP applications on Win 2008 Server and Win 7 - Possible Solutions|http://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/18603] [original link is broken] [original link is broken] [original link is broken];.

Ludek

Follow us on Twitter http://twitter.com/SAPCRNetSup

Former Member
0 Kudos

Hi Ludek,

It worked !!!

In RDCrptserver11.asp or RDCrptserver115.asp you should change the first occurrence of response.addheader "CONTENT-LENGTH", lenb(temp) to response.addheader "CONTENT-LENGTH", lenb(temp + 0). Then it displayed the report in the viewer.

Your article /people/ludek.uher/blog/2010/04/06/report-designer-component-rdc-in-classic-asp-applications-on-win-2008-server-and-win-7--possible-solutions has all this information.

Thanks,

Amit.

former_member183750
Active Contributor
0 Kudos

Excellent. Good to know some of this stuff does work :).

Happy coding,

Ludek

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi, Ron;

There should not be any issue on Windows 2008.

What type of application is it, .NET, VB, ASP ?

How did you deploy the application to Windows 2008?

Regards,

Jonathan

Follow us on Twitter u2013 http://twitter.com/SAPCRNetSup