cancel
Showing results for 
Search instead for 
Did you mean: 

Activate Mobile Services in HCP trial account

soumya_nandi
Participant
0 Kudos

Hi All,

I have enabled the mobile services for my trial account in HCP. I have also enabled the Hybrid application toolkit for my webide project. But the sub-menus of the Mobile are not coming to deploy the app as a mobile application. I am getting below message as well while opening the web ide,

Please let me know what I am missing here. Is there anything else I am missing which is required as part of activation of the mobile service in HCP?

Regards,

Soumya

Jitendra_Kansal
Product and Topic Expert
Product and Topic Expert

lnoens can share some inputs here?

Accepted Solutions (1)

Accepted Solutions (1)

LudoNoens
Product and Topic Expert
Product and Topic Expert
0 Kudos

The extension Mobile Services App Development Tools should have no influence on the behaviour of the Hybrid App Toolkit extension.

What is very likely missing, is a destination on SAP Cloud Platform, called 'mobileservices'.

Please check your Destinations in the SAP Cloud Platform cockpit and ensure you have the destination. Example below:

soumya_nandi
Participant
0 Kudos

Hi Ludo,

Do we need to add this destination manually or it will automatically gets added when we activate the service?

Regards,

Soumya

soumya_nandi
Participant
0 Kudos

Hi Ludo,

Adding that in destination solved my issue. Thanks a lot.

But when I tested the connection after adding the destination I got 401 unauthorized error. Is it because I kept the authentication as AppToAppSSO and when webide is trying to access the mobile services at that time the authentication works?

Regards,

Soumya

Answers (3)

Answers (3)

LudoNoens
Product and Topic Expert
Product and Topic Expert

Hi Soumya,

The destination should be added automatically when you activate the service in the SAP Cloud Platform Cockpit. But this might have been removed for some reason.

And yes, the App2App SSO will be handled through SAP Web IDE.

Cheers,

Lufo

soumya_nandi
Participant
0 Kudos

Hi Phil,

It is also activated inside webide. That is why that error message is coming when I open the webide. If I disable the same then no error message comes. Please let me know, if you need further clarification from my side.

Regards,

Soumya

pjcools
Active Contributor
0 Kudos

Hi Soumya

Are you able to provide some more information here? The Mobile Services functions are enabled via another preference setting. To see the mobile options within the SAP Web IDE Full Stack you will need to activate this.

Activate this and see how you go.

Thanks & Kind Regards

Phil Cooley