Showing results for 
Search instead for 
Did you mean: 

Accessing Crystal XI by Default

Former Member
0 Kudos

We have two versions of Crystal Reports installed on a computer - Crystal XI (crw32.exe, installed on 5/4/2008 to C:\Program Files (x86)\Business Objects\Crystal Reports 11.5) and Crystal for Peachtree (crw.exe, installed on 9/27/2008 to C:\Program Files (x86)\Business Objects\BusinessObjects Enterprise 12.0\win32_x86) This problem comes when I open a report, it accesses Crystal for Peachtree but I need it to access Crystal XI by default. 
I've gone into Control Panel>Default Programs>Associate File Type with Program and pointed the default program to Crystal XI but it still opens in Crystal for Peachtree.  I've also modified the registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.rpt and edited the OpenWithList but all to no avail.  How do I fix it so it opens Crystal XI by default?  We are running server 2008.

Thank you,

Patrick Rose

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi Patrick,

I pinged the rest of the team if they knew of any reason why and how to make this work and Trevor found this MS forum post, it's long, on people having the same issue.

Possibly you can ask Peechtree if they are enforcing it. Or maybe install XI R2 first, could be the order you install that takes priority...

MS Forum Post:


Former Member
0 Kudos

Thank you.  Within that article, I found the following information that worked to resolve the issue:

In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.

Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.

Answers (0)