cancel
Showing results for 
Search instead for 
Did you mean: 

ABAP Programming Error, OBJECTS_OBJREF_NOT_ASSIGNED, SAPLRSBK_AFTER_IMPORT

Former Member
0 Kudos

Hi All,


When I trying to transfer request, the Program terminated  (Method Execution       (12) Canceled)


I get a dump as detailed below.

*********************************************************************************************

Category               ABAP Programming Error

Runtime Errors         OBJECTS_OBJREF_NOT_ASSIGNED

ABAP Program           SAPLRSBK_AFTER_IMPORT

Application Component  BW-WHM-DST


Short text

     Access via 'NULL' object reference not possible.

What happened?

     Error in the ABAP Application Program

     The current ABAP program "SAPLRSBK_AFTER_IMPORT" had to be termin

      it has

     come across a statement that unfortunately cannot be executed.


Error analysis

    You attempted to use a 'NULL' object reference (points to 'nothing')

    access a component (variable: " ").

    An object reference must point to an object (an instance of a class)

    before it can be used to access components.

    Either the reference was never set or it was set to 'NULL' using the

    CLEAR statement.

*********************************************************************************************


We are on:

SAP_BASIS         731         0009

SAP_ABA            731         0009

PI_BASIS             731         0009

ST-PI     2008_1_710       0008

BI_CONT             747         0006

SAP_BW              731         0009

ST-A/PI                01Q_731              0000

Help in fixing this issue is appreciated.

Thanks


Accepted Solutions (0)

Answers (3)

Answers (3)

former_member209606
Participant
0 Kudos

hi

before transporting do u enhance any fields in your datasource??

Former Member
0 Kudos

Hello,

Can you tell us what kind of modification you are trying to apply to your cube?

For example, if you try to delete a field and you transport this modification to quality without deleting the contents of your infocube, you will get this kind of error.

RamanKorrapati
Active Contributor
0 Kudos

Hi,

Please let us know what objects your transporting or which objects are collected into transport.

All collected objects are in active and in sequence?

Thanks

Former Member
0 Kudos

Hi,

I transported infocube, DTP, infoObj, infopackage, DSO, transformation. All of these obj are in active and in sequence. All of them was transported successfully, except for InfoCube. When i tried to transport InfoCube separately, import ended with error:

*********************************************************************************************

Start of the after-import method RS_CUBE_AFTER_IMPORT for object type(s) CUBE ( )

Error/warning in dict. activator, detailed log  -> Detail

No active nametab exists for /BIC/DXXXXXXX1

Termination due to inconsistencies

Table /BIC/DCZFM_C031 (Statements could not be generated)

No active nametab exists for /BIC/DXXXXXXX2

Termination due to inconsistencies

.....

DDIC Object TABL /BIC/DXXXXXXXP has not been activated

Error when activating InfoCube XXXXXXX

Object CUBE XXXXXXX imported with errors on this request

Errors occurred during post-handling RS_AFTER_IMPORT for APCO L

RS_AFTER_IMPORT belongs to package RSO_TLOGO

The errors affect the following components:

   BW-WHM-MTD (Metadata (Repository))

*********************************************************************************************

chanda
Contributor
0 Kudos

Hi ,

Please check if all the info objects used in the cube have been transported & Active in state.

Then try to collect the cube in a new request and re transport.

Hope it helps.

rgds,

sudhir

RamanKorrapati
Active Contributor
0 Kudos

Hi,

With out success of info cube how you transport dtps.  please understand sequence of objects and collect object into individual transports. its easy to error free from transport issues.

Error mentioning that info cube dimensions are not in active  data packet dimension not in active.

at dev system, reactivate your info cube and collect into new transport.

Thanks

Former Member
0 Kudos

I reactivated InfoCube and transported it with all data flow before by Transport Connection. But the message didn't change:

*********************************************************************************************

Start of the after-import method RS_CUBE_AFTER_IMPORT for object type(s) CUBE ( )

Error/warning in dict. activator, detailed log  -> Detail

No active nametab exists for /BIC/DXXXXXXX1

Termination due to inconsistencies

Table /BIC/DCZFM_C031 (Statements could not be generated)

No active nametab exists for /BIC/DXXXXXXX2

Termination due to inconsistencies

.....

DDIC Object TABL /BIC/DXXXXXXXP has not been activated

Error when activating InfoCube XXXXXXX

Object CUBE XXXXXXX imported with errors on this request

Errors occurred during post-handling RS_AFTER_IMPORT for APCO L

RS_AFTER_IMPORT belongs to package RSO_TLOGO

The errors affect the following components:

   BW-WHM-MTD (Metadata (Repository))

*********************************************************************************************

Earlier all was good. Its problem appeared after upgrade system.

RamanKorrapati
Active Contributor
0 Kudos

Hi,

As your at dev system, is it possible to delete your info cube and recreate it again.

info cube dimension tables are creating problem.

Dim - TABL /BIC/DXXXXXXXP

                      BIC/DXXXXXXX1

                BIC/DXXXXXXX2

Above 3 are info cube dimensions, not sure why those are inactive during the transport.

Try to adjust and actiavte above tables at dev system and quality system by uisng Tx - SE14. later try to import the same transport into quality.

Thanks

Former Member
0 Kudos

In dev system cube is active, but in quality is not. When I try to activate it in quality system, the next message is following:

RamanKorrapati
Active Contributor
0 Kudos

am unable to see/read attached message. can you attach in jpeg format

Former Member
0 Kudos
RamanKorrapati
Active Contributor
0 Kudos

hi,

There is some DB issue, its not allowing to actiavte your info cube. take DB team help and check it out. its not allowing to actiavte the info cube.

as stated above dim tables, need to be active, have your tried to activate them by using SE14.

if possible try to crate new info cube and use it.

Thanks