cancel
Showing results for 
Search instead for 
Did you mean: 

A value missing from Toggle group tree

Former Member
0 Kudos
41

Hi,

We are currently using CR XI R2 and a value was missing from a toggle group tree and even the report as shown below,

+Open

+Closed

+ Value missed

+Partially Open.

The same value is not displayed even in the report, but when the value is expanded, there are other ids present under it. For this group, below formula is used to display the color for each status and the color also is not showing up for that value in the report.

IF {@Status} = "CLOSED" THEN BLUE ELSE

IF {@Status} = "OPEN" THEN RED ELSE

IF{@Status} = "VOIDED" THEN GRAY ELSE

IF{@Status} LIKE "PARTIAL*" THEN GREEN ELSE YELLOW;

Can anyone help me on this?

Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

Hello,

Not clear what the problem is but could be case sensitivity...

Try this:

IF UpperCase({@Status})....

And you may need to test for Null values using the IsNull

IF Not isNull(UpperCase({@Status}))....

Don

Former Member
0 Kudos

Thanks Don, I tried the way you suggested and it dint work.

0 Kudos

I guess "dint" means "did not" ?

Try dropping the formula and field in the report also to see what it's actually returning. Then you should be able to see why it's missing the logic.

Don

Former Member
0 Kudos

Thanks Don, I tried that too, but it is still not showing up in the Toggle group tree as well in the report. Only that value is missing.

0 Kudos

OK then only suggestion is to upgrade to CR XI R2A SP 4 and SP 6 and see if that works. If not then upgrade to supported product. R2 is end of life so no more patches.

You can get them from the Download Page.

Don