cancel
Showing results for 
Search instead for 
Did you mean: 

0TCAKYFNM Keyfigure authorization problem

Former Member
0 Kudos
589

i have already made 0TCAKYFNM auth relevany via RSD1

now i have created Auth object in RSECADMIN and added

0TCAKYFNM

but i want to retrict user on key figure material_type Or Material

how can i do that?

Accepted Solutions (0)

Answers (6)

Answers (6)

Former Member
0 Kudos

Hi

i have created ZTEST auth object in rsecadmin and added

it in R_RS_AUTH in Role of that user

that role is assigned to user from which i run that query

0BI_all auth object is not assigned to that user

but still i am getting all material types

Manually Infrastructure of the Analysis Authorizations S_RSEC

Manually BI Analysis Authorizations in Role S_RS_AUTH

Manually BI Analysis Authorizations in Role S:BW_USER_00

BI Analysis Authorizations: Na ZTEST

Manually Business Explorer - Components S_RS_COMP

Manually Business Explorer - Components: Enhancements to the Owner S_RS_COMP1

Manually Data Warehousing Workbench - InfoCube S_RS_ICUBE

Ztest is as follows

0CUSTOMER

0INFOPROV

0MATERIAL

0MATL_TYPE

0TCAACTVT

0TCAIPROV

0TCAKYFNM

0TCAVALID

for 0matl_type i have assigned EQ FERT

Former Member
0 Kudos

Hi

if u r using the navigation attribute 0matl_type of 0material in query, then I guess u shud try to make the nav attribute of 0material as authorization relevant and no need for 0material to be authorization relevant.

rgds

Deepak

Former Member
0 Kudos

Try to trace this using RSECADMIN --> Analysis --> Error Logs. Here, in "Configure log recording" assign the user ID with which you are testing and save it.

Then, try to execute the report with the test ID and check the log from Error logs tab. There could be some other analysis auth assigned to the user which is giving access to values other than FERT.

Former Member
0 Kudos

Hi Chandru

did that also but still i am getting all material types when i run query

Former Member
0 Kudos

Hi

have u included ur authorization object for that user in role maintenace for S_RS_AUTH=ur authorization object by default it will be 0BI_ALL(full authorization) thats why u can see all data.If you have authorization to PFCG u can do or else ask ur basis to add ur authorization object to that particular role.At query level u have to create authorization variable of type not ready for input and represents multiple single values option and restrict ur query with those variables in filter.

Regards

Former Member
0 Kudos

Hi Chandru

yes i did the same thing but still when i run query i am getting all material types in output

rsather i should get all materials of type FERT

Former Member
0 Kudos

Hi,

Ok Select 0Material and details give value as CP'*'you should be able to see selcted materials for that material type.

Former Member
0 Kudos

i have made all these auth relevant and added in rsecadmin

0CUSTOMER

0INFOPROV

0MATERIAL

0MATL_TYPE

0TCAACTVT

0TCAIPROV

0TCAKYFNM

0TCAVALID

also given value to matl_type as 'FERT'

but still when i run query via user who has given this auth object ,i can see all material types.

Former Member
0 Kudos

Hi Nitin,

For ur authorization object Select 0MATL_TYPE and Details icon and give value as EQ FERT.let me know if u still face problem.

Regards

Chandru

Former Member
0 Kudos

Hi Chandru

i want to restrict on 0material characteristic and 0matl_type

so how can i create auth object in rsecadmin ?

Former Member
0 Kudos

Hi Nitin,

0TCAKYFNM,0TCAIPROV,0TCAACTVT AND 0TCAVALID are special characteristics SAP is sugesting to insert in authorization objects.making them authorization relevant and adding in authorization objects is a primary thing.But on what basis u want the user to restrict data based on companycodes or his/her salesregions? 0Material is not a keyfigure its a characteristic.for this characterstic on what keyfigure values you show?Stock values?Can you be more specific.

Regards

Chandru