Technology Blogs by SAP
Learn how to extend and personalize SAP applications. Follow the SAP technology blog for insights into SAP BTP, ABAP, SAP Analytics Cloud, SAP HANA, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
RolandKramer
Product and Topic Expert
Product and Topic Expert

last changed: 12th of April 2023



SapMachine is an OpenJDK released maintained and supported by SAP.
You can replace the in-build JAVA Support from the SAP HANA Studio with SapMachine.


You can use this to replace any existing JAVA (owned by Oracle) deliveries on you local Frontend or Terminal Server. Download the 64-Bit binaries either as

  • zip archive (allows you own location)

  • installation packages


Make sure that you adapt the Environment of your Frontend for SapMachine as well, like

  • JAVA_HOME

  • SAP_JRE8_64

  • JavaFX

  • Path


Edit the File C:\Program Files\SAP\hdbstudio\hdbstudio.ini

And replace the -vm parameter with the SapMachine
Old:       plugins/com.sap.ide.sapjvm.jre.win32.x86_64_110.11.0/jre/bin
New:      c:/usr/sap/sapmachine-jdk-18.0/bin
macOS: /Applications/sap/SAPGUI/SAPGUI.app/Contents/PlugIns/jre/Contents/MacOS/libjli.dylib
-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.6.400.v20210924-0641.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.2.700.v20221108-1024
--launcher.XXMaxPermSize
512m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
#../Eclipse/plugins/com.sap.ide.sapjvm.jre.macosx.x86_64_110.17.0/jre/Contents/Home/lib/jli/libjli.dylib
/Applications/sap/SAPGUI/SAPGUI.app/Contents/PlugIns/jre/Contents/MacOS/libjli.dylib
--add-modules=ALL-MODULE-PATH
--module-path=/Applications/sap/javafx-sdk-20/lib
--add-exports=javafx.web/com.sun.webkit.dom=ALL-UNNAMED
-vmargs
-Xms512m
-Xmx2048m
-XX:MaxPermSize=1024m
-Dfile.encoding=UTF-8
-Duser.language=EN
-XX:+HeapDumpOnOutOfMemoryError
-Djdk.http.auth.tunneling.disabledSchemes=
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dcom.sap.adt.tools.cloud.authentication.ui.cloud.pilot.project=true
# in case of Problems with local SSL store
# -Djavax.net.ssl.trustStore=NUL
# -Djavax.net.ssl.trustStoreType=Windows-ROOT

 


the latest SAP HANA Studio Version starting from 2.3.60 and onwards are now completely compiled with JAVA 11 due to a lot of incompatibilities between the Version JAVA (SDK) 8 and 11. As mentioned in the comments you can also use SapMachine 17/18 instead of 11.


with macOS, you can use the homebrew package manager to apply sapmachine18-jdk




Troubleshooting related to SAP HANA Studio


the current Versions of the SAP HANA Studio are not working on the new Apple Silicon (M) Devices. It is related to the latest Update of the macOS Version 13 (Ventura) – https://github.com/eclipse-platform/eclipse.platform.swt/issues/256

For Eclipse 2023-03 (4.27), use https://tools.hana.ondemand.com/2023-03
For SAP for Eclipse 2022-06 (4.24), use https://tools.hana.ondemand.com/2022-09
The SAP HANA Client for macOS, use https://tools.hana.ondemand.com/#hanatools

Note 3198962 - SAP HANA 2 SPS06 Revision 063.00 => Version 2.3.70
Note 3259825 - SAP HANA 2 SPS06 Revision 066.00 => Version 2.3.71
Note 3312617 - SAP HANA 2 SPS07 Revision 070.00 => Version 2.3.73

Note 2073112 - FAQ: SAP HANA Studio

If you encounter Problems with the SAP HANA Studio Version 2.3.60 and higher, e.g. 2.3.61 delivered with the latest SAP HANA Studio Versions, you can also check the Document

In particular, a "new" error message arise which caused already problems in the past. This occurrence leads rather to the external JDK Support or mismatch of the used JDK Version. Sometimes only a new Installation solves this problem.



SAP Answers - ADT 3.18 stopped working on Eclipse 2021-06
SAP Answers - JavaFX 13 and Eclipse


mismatch between JAVA 8 and 11



optional: Delete Database and Cache will not solve the Problem


 




SAP HANA Studio and SAP GUI 7.70


Note 2600384 - New and changed features in SAP GUI for Windows 7.60
Note 2796898 - New and changed features in SAP GUI for Windows 7.70
Note 3204095 - SAP GUI for Java: Requirements for Release 7.80

If you are using SAP GUI 7.70 together with the SAP HANA Studio, you probably encountered that the Internet Explore 11 is not supported anymore. So you have to switch at both locations (GUI and Studio/Eclipse) to the Microsoft Edge (based on Chromium) Support.

Note 1672817 - Browser: Microsoft Legacy Edge and Internet Explorer Support Policy Note
Note 1716423 - SAPUI5 Browser Support
Note 2971147 - Using JavaFX with Java 11 for embedded GUI in ABAP Development Tools (MacOS / Linux)
Note 3043532 - Web Dynpro app opens always in Internet Explorer (IE11) when called from SAPGUI
Note 3048479 - WDA: Execute Application According to Browser Mode Setting
Note 3031743 - WebGUI Health Check feature

Blog - Update: Future SAPUI5 versions will no longer support Microsoft’s legacy browsers
Blog - Installing lean Eclipse with ADT


check SAP HANA Studio 2.0 - Preferences




switch to the external Browser Support


 




SAP HANA Studio and SAP GUI for Java 7.80


beginning with SAP GUI for Java 7.80 the native support of Apple ARM Chips (aka. M1/M2) is available. However, the SAP HANA Studio for macOS is still INTEL based. You have to decide, wether you want to work with the native Eclipse Application for macOS ARM, or the SAP HANA Studio with the SAP GUI for Java 7.80 for X86_64


SAP HANA Studio and SAP GUI for Java 7.80 (x86_64 based)


 




Note 2487028 - How to open /UI2/FLP to run it on default browser
Note 2616249 - How to achieve SSO while opening Fiori Launchpad using t-code /UI2/FLP
Note 3129284 - FLP start with / without SSO and default browser (new FLP setting)


check SAP Logon 7.70 GUI Settings



check Web Dynpro Settings in SE80


Note 3009338 - SOLDOC: SAP GUI office Integration


Online Edition with Edge and GUI 7.70, e.g. SolMan 7.2 SP13 and higher


 




Eclipse Add-On's AiE and BW-MT


Note 3035242 - Remove bundled JRE from Eclipse packages
Note 3226606 - RTC of ABAP development tools 3.28
Note 3236198 - Unable to start ADT debugger from BW Projects
Note 3203171 - Modeling Tools for SAP BW/4HANA and SAP BWoH : Release 1.24 Patch 04

Always check with the online resources at - https://tools.hana.ondemand.com/#

SAP First Guidance – Implementing BW-MT as the new SAP BW Modeling Experience




check SAP HANA Studio 2.0 - Installed SAP Add-On's


 






Roland Kramer, SAP Platform Architect for Intelligent Data & Analytics
@RolandKramer


 

“I have no special talent, I am only passionately curious.”
5 Comments