Technology Blogs by SAP
Learn how to extend and personalize SAP applications. Follow the SAP technology blog for insights into SAP BTP, ABAP, SAP Analytics Cloud, SAP HANA, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
OliverGraeff
Product and Topic Expert
Product and Topic Expert


SAPUI5 is constantly innovating with new capabilities and at the same time providing patches for delivered versions on several platforms. For details see the version concept and the SAPUI5 maintenance strategy and SAPUI5 Versions Maintenance Status summarized here.



What?


SAP plans to refactor the SAPUI5 JAVA component used in SAP NetWeaver JAVA, potentially affecting customer landscapes using SAP NetWeaver JAVA with e.g. SAP Enterprise Portal.



Why?


The reasons for this change are:




  • Deploying this component takes too long because of its size. The new components will be considerably smaller and faster to deploy.

  • The SAPUI5 JAVA component contains SAPUI5 versions (1.44; 1.52 and 1.60) which are out of maintenance, i.e. not receiving any patches. This potentially affects the stability of productive environments for customers. Most importantly, these versions pose a security risk, as newly detected security issues e.g. in browsers or other web technologies cannot be not fixed.


How?


The SAPUI5 team plans for two phases to re-factor the SAPUI5 JAVA component (UISAPUI5_JAVA) for SAP NetWeaver JAVA, see details in SAP note 3293000:


1. Phase: Refactoring the structure of UISAPUI5JAVA*.SCA in SAP NetWeaver JAVA 750 SP28 (planned for September 2023)

Moving SAPUI5 1.44, 1.52 and 1.60 to separate Software Deployment Archive (SDA) in that component. This will improve deployment times, as SDAs are deployed in parallel. See details and what needs to be adjusted in SAP Enterprise Portal in . (and later).


2. Phase: Removing the outdated SAPUI5 versions from SAP NetWeaver JAVA 750 SP29 (planned for March 2024)

SAPUI5 versions 1.44, 1.52 and 1.60 are removed from the component, reducing its size to around 45% and improving deployment times. This is the physical deletion of out-of-maintenance versions from the SAPUI5 JAVA component. Should you still need those versions for a productive scenario, we have SAP note 3293029 - How to install SAPUI5 1.44, 1.52 or 1.60 on NW 7.50 SP29 and later providing a fallback solution. Please keep in mind that SAP strongly advises against this solution, i.e. against using SAPUI5 versions which are out of maintenance, e.g. for security reasons.



What to do?


Please make sure you are not using SAPUI5 versions which are out of maintenance. See details in:




In case you are using SAPUI5 1.44, 1.52 or 1.60 from SAP NetWeaver JAVA, make sure to update to a supported version as soon as possible. For this see the details in the documentation on SAP NetWeaver 7.5 -> Implement -> Upgrade and Update Guides for SAP NetWeaver 7.5.