Technology Blogs by SAP
Learn how to extend and personalize SAP applications. Follow the SAP technology blog for insights into SAP BTP, ABAP, SAP Analytics Cloud, SAP HANA, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
ZackFrazier
Product and Topic Expert
Product and Topic Expert
0 Kudos
834

Attention Work Manager, Cloud Edition and Inventory Manager, Cloud Edition customers:


Please be aware that action may be required on your part to prevent a disruption in your SAP Cloud production landscape after the Agentry Cloud Edition (ACE 2202) release on April 25, 2022.


Who must take action?


Customers running any of the following product versions:

  • Work Manager 6.6.0

  • Work Manager 6.5.11 or earlier

  • Inventory Manager 4.4.0

  • Inventory Manager 4.3.8 or earlier


If you are running one of these versions, they will no longer function correctly in the SAP Cloud production landscape after April 25, 2022.

Work Manager 6.6.1, Work Manager 6.5.12, Inventory Manager 4.4.1, and Inventory Manager 4.3.9 are compatible with the forthcoming ACE 2202 release.

What must be done?


It is required that you apply SAP Note 3156057 - SAP Work Manager - SAP Inventory Manager - ACE installation dependency upgrade as soon as possible.

Once updated, the application deployment zip file must be tested in the ACE development and/or preview landscapes. ACE 2202 is already released to the development and preview landscape and is currently available for testing.

Once validated, the upgraded application deployment zip file must also be published to the production landscape. The updates described in SAP Note 3156057 have been validated against both the current ACE 2106 release and the forthcoming ACE 2202 release.

When must this be completed?


Before April 25, 2022 when the next release of Agentry Cloud Edition is scheduled for release to the production Neo SAP Cloud Platform.

Why is this necessary?


We identified a compatibility issue when running specific earlier versions of Work Manager Cloud Edition and Inventory Manager Cloud Edition.

The ACE 2202 includes mandatory security updates to various open source components. Specific libraries included in the earlier Work Manager and Inventory Manager products are not compatible and must also be updated prior to the ACE 2202 rollout.

Cloud deployments of Work Manager and Inventory Manager require a library dependency upgrade to remain compatible with newer versions of ACE. If you are running the older, incompatible log4j libraries, you may see error messages similar to the following:
Error starting Java System Connection Java Back End: 
java.lang.NoClassDefFoundError: org/apache/logging/log4j/util/PropertiesUtil :
cannot initialize class because prior initialization attempt failed;

How to get support?


Our product team recognizes this is an inconvenience for our customers and we encourage you to reach out with any questions or concerns. The Work Manager, Inventory Manager, and Agentry Cloud Edition teams are watching all Service Now tickets closely and will expedite assistance related to this required update.