Technology Blogs by SAP
Learn how to extend and personalize SAP applications. Follow the SAP technology blog for insights into SAP BTP, ABAP, SAP Analytics Cloud, SAP HANA, and more.
Showing results for 
Search instead for 
Did you mean: 

I have wanted to post a blog in the SAP HANA space for some time now, but I struggled initially to identify the right opportunity.  The desire is to write something helpful and, until recently, I wasn't sure I possessed the right level of knowledge to contribute in a meaningful fashion.  Fortunately my Analytics background finally paid off, and Lumira Server gave me the shot I was looking for...

You may have recently heard about Lumira Server becoming Generally Available and I would have been remiss had I not taken the opportunity to install it immediately on my HANA SPS07 instance.  I had previously installed the Customer Validation (CUV) build at release level 1.14 and the Lumira Server user guide states explicitly that you must uninstall a previous version of the delivery unit before importing the latest version. Personally I think this is a bit superfluous as HANA gives you the ability to overwrite or reactivate existing delivery units, but I've enough experience with SAP product to follow the directions and not argue.

The instructions go something like this:

On your SAP HANA system, navigate to the hdbclient directory where regi program is located

  1. On your SAP HANA system, navigate to the hdbclient directory where regi program is located.
  2. At the command line, enter the following: export REGI_USER= <USERNAME>.

    Replace <USERNAME> with your SAP HANA system administrator name.

  3. Enter the following: export REGI_PASSWD=<PASSWORD>.

    Replace <PASSWORD> with the SAP HANA system administrator password.

  4. Enter the following: export REGI_HOST=<HOST>:3<INSTANCE>15.

    Replace <HOST> with the server name and <INSTANCE> with XS Engine port number. For example, if you are using instance 27 on myserver enter: export REGI_HOST= myserver:32715.

  5. Enter the following:

  • To undeploy 1.14 or newer, enter: regi undeploy LUMIRA_SERVER
  • To undeploy versions earlier than 1.14 enter: regi undeploy HANA_EXP_WEB

The delivery unit is undeployed and you can install the latest support package.

I ran this on Windows though so the commands were a bit different.  Specifically, I ran:



set REGI_HOST=host:30015

instead of export as you would on a Unix based system.

Once this completed successfully I was able to install version 1.15 of Lumira Server and be on my way ... or so I thought.  This process coincided with me updating my HANA server to Revision 72, along with Studio and the corresponding client components.  However, I started noticing a constant issue shortly thereafter where activation of new code caused HANA Studio to hang.  Exiting the application had the same effect...

As a relative newcomer to troubleshooting HANA Studio issues, I assumed it was related to Rev 72.  I even tweeted the following (incriminating me in the process):

Note the nefarious "Build Workspace" message that never disappeared.

I scoured the internet for explanations, even altering some .ini files in the hope of rectifying the situation (note: appending -clean to my eclipse.ini file had no impact on the integrity of my install).

I was completely hobbled in my ability to activate any new code, and since I was in the midst of consuming the excellent SAP River Tutorials it was a constant struggle for a few days.  In my utter frustration I nearly broke down and uninstalled studio altogether, but I'd done enough customization (i.e. changing perspectives, adding the River plugin, etc.) that I hoped to avoid it if possible.

I decided to use the excellent Process Monitor (ex-SysInternals now owned by Microsoft) to examine my problem a bit deeper.  It paid off in spades and I can't say how pleased I was to have this familiar tool, often used to troubleshoot BI issues, solve a HANA Studio problem just as effectively.  Process Monitor identified a .lock file in the C:\eclipse\HANA\LumiraServer\._SYS_REGI_settings directory that HANA Studio couldn't delete.  I had tried launching Studio as Administrator, as well as the default, so I'm not sure what prevented me from deleting the file, but manually removing the lock file restored full functionality to my HANA Studio.

Here was the culprit:

I hope this post helps you if you run into a similar problem, and I couldn't be happier to find such utility out of Process Monitor.  At the end of the day, I spent some time living with and then troubleshooting an issue that left me with a much improved understanding for how HANA Studio works, and the satisfaction of solving a problem without uninstalling (and losing) the considerable amount of work I'd already performed.