Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 

We know the importance of generating BO traces without requiring a restart and how it helps us either to perform a root-cause-analysis or to dig-n-dive deep.  But then, when the work is done the logs are too huge (of course, we did need it that excessive and intensive) but it consumes tremendous disk space (I'm talking gigs).

You certainly do have a way to stop it- but sometimes the standard way doesn't work - Apparently and evidently, I have seen this at least couple of times in my life, that when you stop the server tracing by setting the parameter active = false in the trace.ini file, even then the parameter DOES NOT allow the traces to be stopped.  The tracing level option at the server properties level is ALREADY set to none (if BI4.x)- and (if XI 3.1 - there is no -trace applied) still no luck. This situation is though not common; but I have seen with other customers as well.

Please see Tracing in SAP BusinessObjects Enterprise XI3.1 on how to set tracing without requiring a restart of servers

This goes on for days; now your logs keep filling i.e. no. of servers * every 60 seconds of poll time * no. of days = problems :lol:

Let's cheat with Logs now :wink:

In this case what best you can do is, it reads the other parameters - the trick is with the parameter

log_dir =  <folder path of logs where it is to be generated> by default, this parameter has value = \logging\

This is the folder that defaults to the logging folder in the installation directory of the BusinessObjects, unless explicitly specified.


Simply change the location of the folder path where logs are generated to something which doesn't exists on your computer.  I take this funny example, I don't have any folder called "logs_please_dont_appear" under any drive :grin:

Now what I do is, I specify this as the location for the parameter log_dir = C:\logs_please_dont_appear

How this works - it wants to now generate traces but it doesn't find the location to put the logs for.  Interestingly, since I've cheated it - now the logs just don't appear - as you have convincingly pleased the logs to not appear :razz:


I don't say to follow this as a usual practice to stop tracing but this will certainly help when it doesn't stop normally.  If you ask, what if the log_dir parameter is not readable as well (it never did for me at least in my lifetime) -  I would happily advice you to knock SAP's door.  This blog creates enough awareness on how you can also stop the logs to generate when in this situation.

Very Important Note - This is my first blog :cool:

Labels in this area