Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Hello All,

Its been some time that I have been working in HANA and related areas like SLT, Lumira, Fiori and so on.

So thought of sharing some topics here, which would be handy.

Disclaimer :

1) This series is exclusively for Beginners in HANA and all those HANA experts here, please excuse me

2) These are some Solutions/observations that we have found handy in our projects and am quite sure there would be multiple ways to derive the same result.

3) These series of documents are collaborative in nature. So please feel free to edit the documents,wherever required!

4) All the points mentioned here is observed on HANA systems whose revision is >= 82.

Part 1 of this series can be found here --> Tips, Experience and Lessons Learned from multiple HANA projects(TELL @ HANA - PART 1)

Part 3 of this series can be found here -->  Tips, Experience and Lessons Learned from multiple HANA projects(TELL @ HANA - PART 3)

Part 4 of this series can be found here -->

13) Related to HANA:

Use Case: You already have a HANA system configured in Studio.

Once you log in, you could see that 'SAP Control REQUEST HAS FAILED' even though the services are all started.

Solution: In most cases, remove the system from the studio and add the same system again.

It should start again without any issues.

14) Related to HANA:

Use Case: My customer had sent me a excel file (which looks like the following) and I was asked to load the same into a schema table in HANA.

Please note that there is a COUNTER Column having value 1 in each row.

When we upload, we are getting an error like the following:

'INSERT, UPDATE and UPSERT are disallowed on the generated column: Cannot insert into the generated field COUNTER'

Work around: We had tried many options but nothing was working out for us.

So we deleted the 'COUNTER' column from the excel and then uploaded the data.

Later using an ALTER Statement, we were able to include the 'COUNTER' column aswell.

PS: The actual reason for this error is still not clear, but could see some interesting discussions about this here in SDN.


15) Related to HANA:

Use Case: My customer had sent me a excel file (which looks like the following) and I was asked to load into a schema table in HANA.

We were trying to upload the data to HANA, where the Data type of the above 2 fields 'DATEA' and 'LDATE' was 'DATE'.

Upload from Flat file was throwing the following error.


Workaround: We had to change the data type of the fields 'DATEA' and 'LDATE' to 'NVARCHAR'.and the data was successfully uploaded.

This was a just a workaround and am not sure if we have a permanent solution for this issue.

Another Work Around for Loading Date fields from excel to HANA:

In HANA side, keep the corresponding column as date data type.

Go the CSV file and do the following modification and save the csv file.

Now try loading the table to HANA using Data from Local file option  and it will be successful.

PS: Even after saving the csv file, you might see the excel column in the old format, but dont worry, the loading will be successful.

This will work only in cases, where you dont have a null value under the date column.

16) Related to HANA/ ABAP Development Tools

Use Case: We had to do of a debugging a procedure in an Promotion Management System running on HANA database.

We we clicked on the particular procedure, it showed us a message 'Please use the ABAP development tools in Eclipse'.(SE80 screen is shown below)

Solution: We had to configure ABAP perspective in Eclipse/Studio and were able to proceed with debugging.

Please see some interesting documents on the related topic here:

ABAP Managed Database Procedures - Introduction

Tutorial: How to Debug an ABAP Managed Database Procedure

Post configuring the ABAP Perspective, we will be able to log into the ABAP system using the same.

The above shown screen of SE80 in ABAP perspective will look like the following in HANA Studio.

17)  Related to HANA/ ABAP Development Tools

Use Case:  We had to install 'ABAP Development Tools' in HANA Studio.

Solution: Please follow the steps mentioned by Senthil in the following document.

Step-by-step Guide to setup ABAP on HANA with Eclipse

When you follow the document, at one point you will have to select the required add-on's.

Once the steps are successfully completed, you would be able to see the following perspectives(selected ones from the previous screen) in your Studio:

18) Related to HANA Studio/Eclipse Environment

Use Case: While working in HANA studio, an error 'Failed to create Parts Control' occured.

Observation: This error is some how related to Eclipse environment.

The workaround we had done was to close the studio and run again.

We had observed this error in the following environment:

HANA Studio version is

HANA system version is

Please find an important discussion on this topic here:

Failed to create the part's controls

19) Related to HANA Studio/Citrix Environment

Use Case: This was observed in an Internal Citrix environment and is not expected much in customer projects.

The Studio fails to load and shows the following error message:

Solution: This is an error related to workspace space issue.

HANA studio settings were reset and a new workspace(which has a larger space) was assigned to the new studio installation.

20) Related to HANA

Use Case: I was trying to load a flat file to HANA and I was getting Scientific notations in some columns


Initially, I was trying to load an .xlsx file and I was getting the Scientific Notations.

EX like below:

Then I Changed the .xlsx to .csv (File --> Save as --> .csv) and loaded again to Hana and ioutput was coming as expected:

EX like below:

One more thing what I could observe was that if I change .xlsx to .csv by simply changing the extension and then load to HANA, I was getting something like below:

21) Related to HANA Studio/Eclipse Environment

Use Case: We had installed the plugin's like 'ABAP' and was working in that perspective.

Due to some action, we were getting the message: 'Secure Storage is Locked'.

Observation: The functional part of the secure storage is documented by Rocky in his blog here:

The "not quite" secure storage HANA Studio, Reconnect your Studio to HANA Servers!

You can also find a very detailed discussion about this topic here:

"Error when connecting to system" or "Invalid Username or Password" with HANA Studio

Solution: We followed the following path and deleted the related contents and restarted again.

Hope this document would be handy



Labels in this area