Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 
Active Contributor
0 Kudos


I recently performed a service pack upgrade of a SAP CRM 7.0 system for one of our customers. Although the upgrade was only from service pack level 8 to service pack level 10 I encountered quite some problems. In this document I've collected the errors we encountered during the service pack upgrade as well as the relevant notes to solve them. Furthermore, I've collected the mandatory post installation activities that need to be performed after each service pack upgrade.

Post Installation Activities

  • Activating the SICF service

In order to being able to login to the CRM Web UI again I had to activate the necessary SICF service. Note 1295006 - Mandatory SICF services for IC WebClient contains a list of all SICF service that need to be active in order to use the CRM Web UI

  • Adaptation of the component enhancements

After every service pack or EhP upgrade all enhanced Web UI components need to be checked and maybe adapted. The following notes describe the necessary steps:

Note 1122248 - Consultation:Procedure when dealing w/framework enhancements

Note 1570869 - Adaption of enhancements after SP or release upgrade

In our case I wasn't able to perform the first two steps described in Note 1570869 using transaction WCF_CC. Instead, I had to use transaction WCF_RT_COMP to perform the adjustment of the runtime repository.

Errors after the Service Pack Upgrade

  • SYNTAX_ERROR in the generated program CONTEXT_X_CRM_ADDR_LONG

When trying to log in to the CRM Web UI using the UI role UTIL_IC the system dumped with a syntax error in the program  CONTEXT_X_CRM_ADDR_LONG. The Note 1801092 - Context generation: Syntax error in CONTEXT_X_CRM_ADDR_LONG describes how to solve this problem.


After the problem with the context was fixed the system still dumped when logging into the UTIL_IC role. The reason for this error was the kernel update we performed parallel to the service pack upgrade. Note 1690484 - CX_SHM_NO_ACTIVE_VERSION after installation of kernel 7.20 describes the solution

  • Transaction launcher not working

After the service pack upgrade none of the transaction launcher where working. After the invocation of a transaction launcher the system only displayed a blank page. Note 1620007 - Response registration is missing describes how to solve this problem.

  • Error message "BP category &1 does not fit the data in category &2"

After the service pack upgrade the error message "BP category &1 does not fit the data in category &2" was raised whenever we tried to create a business partner of of the type organisation. This problem was solved by applying Note 1635725 - Error R11 126 on change of title for corporate account.

1 Comment
Labels in this area