Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 
Active Participant
From few versions back, SAP Netveawer is shipped in standard with SAP BW module. The free non-production system delivered by SAP to developers is not an exception, but if you want to develop without any issues, you have to make some small reconfiguration first.


By default SAP NPL instance is configured with a small number of processes. This, of course, is not an issue if you want to develop ABAP, but if you want to run extractor on developer system you probably get an issue like:

  • SMQS scheduler status shows RES_LACK in SQMS transaction

  • You have to manually execute LUW in SM58

  • You can see "status not OK" in monitor

Increase jobs in SAP

All these issues is caused by a lack of resources, let's start with an increasing number of process in SAP.

First, please edit the profile configuration file:
nano /sapmnt/NPL/profile/NPL_D00_vhcalnplci

and a set a number of processes, 16 in my case:
rdisp/wp_no_dia = 16

Now, please restart your application server ( ie. stopsap ALL, startsap ALL).

ASE issue

Unfortunately, this is not the end of our journey. Now if you try to execute info package, or generally do some other work on application server you probably got a dump like:
Database error text: "SQL message: [ASE Error SQL30046:08S01][SAP][ASE ODBC Driver]Connection to the server has been lost. Connection died while reading from socket. ERRNO returned 2. Check the server to determine the status of any open transactions."

If you check your database log, you will probably get:
There are not enough 'user connections' available to start a new process. Retry when there are fewer active users, or ask your System Administrator to reconfigure ASE with more user connections.

To correct this, we have to log in to the database user and change user connections. I have increased the number of connections by 100% from 50 to 100.
su -l sybnpl
isql -Usapsa -X -SNPL
sp_configure "number of user connections"
sp_configure "number of user connections", 100

Now you probably see a message with max memory settings. I recommend changing this value to 764134 and ignore the proposition from the message .

sp_configure 'max memory','764134'
sp_configure "number of user connections", 100

Voila, now extraction should work fine. Let's restart the application server once again.

My database not starting after changes

If something goes wrong, your database could not start now. I had this issue when the first time I change the value to proposition from message. If for some reason your application server won't run. Please execute:

As you see, in my case I have to adjust max memory, to achieve this I have to change config file:
nano /sybase/NPL/ASE-16_0/NPL.cfg

Useful notes:

2564704 - SAP ASE - There are not enough 'user connections' available to start a new process
Labels in this area