Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Hi all,

i came across a strange error last week and it cost me a lot of time and nerves. I had created a BPM model with custom tech tasks, as usual I imported some complex types from ESR and set them as in / output structure. When the structure changed and i tried to re-open the wizard for custom tech... nothing happened. I restarted NWDS several times, "reinstalled" it, tried different versions etc. I clicked the hell out of this button but nothing happened. The log gave me the same error every time:

I searched around in SCN for a solution but could not find any. So i was stalking a bit in the Eclipse community and found this Bug report:


According to this, the error occurs due to badly implemented comparators which where silently ignored in Java 1.6 but since 1.7 they crash. Because i can't do any changes on the SAP Plugins, the workaround was quite simple. Allow the arrays util to use LegacyMergeSort. Just add "-Djava.util.Arrays.useLegacyMergeSort=true" to your ini file and it works again. Issue took so much time and the solution was that easy. I hope SAP is working on this one.

Have fun.



Labels in this area