Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
cancel
Showing results for 
Search instead for 
Did you mean: 
Abhishek_Sinha
Explorer
Recently I was tasked to install SAP BI 4.2 SP05 on RedHat Linux (RHEL) as a part of the on-prem to Cloud migration. While testing it on SoftwareOne's internal lab systems before the actual deployment on the customer's infrastructure I faced lots of issues with the missing OS patches during the installation of BI 4.2 SP5, even after following the standard guide I wasn't able to remediate all the patches. It took a while to collect all the patches required to be present before the installation could begin.

I am summarising the steps I took to resolve the issue which might be of help if someone else is trying the same combination

  • Environment:


OS - RHEL 7.9


App - SAP BI 4.2 SP05


 

  • Issue


The installer failed to start with the following error:


"Installation aborted. The following libraries are required to run the installer:32bit libstdc++ package containing libstdc++.so.5 (eg. compact-libstdc++-33-3.2.3-69.el6.i686)"



Installer fails


Followed the steps mentioned in the following article:

https://help.sap.com/docs/SAP_BUSINESSOBJECTS_BUSINESS_INTELLIGENCE_PLATFORM/65018c09dbe04052b082e6f...

The installer moved ahead but again failed in the prerequisite phase with the below error:

"Failed: Operating system patch level (Critical)

Information: Missing patch: compact-libstdc++-33-3.2.3-72.el7.x86_64"



Prerequisite fails


Resolution:

  • Applied the below patches:


yum install compat-libstdc++-33-3.2.3-69.el6.i686
yum install compat-libstdc++-33.i686
yum install compat-libstdc++-33-3.x86_x64
yum install glibc.i686
yum install libstdc++.i686
yum install libX11-1.3-2.el6.i686
yum install libstdc++.i686
yum install libstdc++.x86_64
yum install compat-libstdc++-33.i686
yum install compat-libstdc++-33.x86_64
yum install glibc.i686
yum install glibc.x86_64
yum install libX11.i686
yum install libX11.x86_64
yum install libXext.i686
yum install libXext.x86_64
yum install expat.i686
yum install expat.x86_64
yum install libgcc.i686
yum install libgcc.x86_64
yum install libXcursor.i686
yum install libXcursor.x86_64
yum install libXrender.i686
yum install libXrender.x86_64
yum install libXfixes.i686
yum install libXfixes.x86_64
yum install libxcb.i686
yum install libxcb.x86_64
yum install libXau.i686
yum install libXau.x86_64
yum install glibc.i686
yum install glibc-common.x86_64
yum install glibc-common.i686
yum install libstdc++.i686
yum install libgcc_s.so.1
yum install libstdc++.so.6
yum install compat-libstdc++-33-3.2.3-72.el7.i686
yum install compat-libstdc++-33-3.2.3-72.el7.x86_64
yum install libX11.i686
yum install libX11.so.6
yum install libXext-1.3.3-3.el7.i686
yum install libXext-1.3.3-3.el7.x86_64
yum install libXext-devel-1.3.3-3.el7.x86_64
yum install libXext-devel-1.3.3-3.el7.i686




  • Yum can also take multiple packages as input (separated by a space) while installing so all the packages can be installed in one go.

    • For eg. yum install glibc.i686 libgcc_s.so.1 ibstdc++.so.6 libstdc++.i686 .......




 

  • After this set the below environment variables:


export LANG=en_US.utf8
export LC_ALL=en_US.utf8




  • Restart the installer


The prerequisite phase passed without any error related to any missing patch



The installer passed the prerequisite checks


After giving all the valid inputs the installer managed to install the BI application successfully.

 

Reference: https://help.sap.com/docs/SAP_BUSINESSOBJECTS_BUSINESS_INTELLIGENCE_PLATFORM/65018c09dbe04052b082e6f...

Conclusion:

The aforementioned steps will ensure you can install BI 4.X successfully on the RHEL 7.X (7.9 in my case) without getting errors for any missing patches on the OS. I hope this helps you with the installation and associated issues, do share your feedback in case you go through it.

Happy Learning!!
3 Comments
Labels in this area