Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 
Former Member
0 Kudos

Trying to get my teeth into MVC coding and javascript, I started looking at ready available packages like JQuery, NodeJS, Cloud9 (and briefly

But what would all this work be getting me, other than knowledge that I cannot apply and some fun, which is short-lived. I am an SAP HANA consultant, MVC is good, SAP UI5 and MVC is better.

First stop after searching was Amazon AWS, where you can cheaply rent SAP HANA One. All very easy to setup, instructions for SAP HANA Studio Windows are provided here, but a bit more difficult for my Mac. After a long search on SCN, people wrote that a SAP HANA Studio Mac version was made available, but shortly after removed from the SAP download portal, I found some help on an external link.

So I installed Eclipse (Luna) which requires the Java SDK on Mac OS X and downloaded all the required plugins to do my SAP HANA cloud development.

Further down the process I wanted to run my instance on AWS, which looked really cheap at $3 an hour (11/11/2014) for a c3.8xlarge EC2 instance type ...

But the overall price estimate scared my wallet off a little - so many hidden costs?

Then I stumbled upon: SAP HANA River

Free at last! Or at least have a good trial run, before spending the money.

After successfully registering using my existing S-User and accepting the terms and conditions I found that I can also connect my local SAP HANA Studio installation to the instance in the cloud.

Trying to follow the documentation in this link failed: SAP HANA Cloud Platform

It just wouldn't let me in.

First tip, do not use the default "Landscape host" entry of "", use as above, correctly pointed out in the instructions ""

Still it wasn't working, there was not instance running apparently ...

So I checked in my cloud deployment and indeed, I just created a database schema and not a proper instance. My fault, so no real tip here.

Trying again, it at least recognised that something was running, but complained: Invalid username and password.

Second tip, "trial" is missing, so I tried "s1234567890trial" (of course with my correct S-User number) in the user name field, but still no luck.

After some head scratching, I asked myself - do I really know the password of my "S-user-trial" account?? No, as it was just mapped to my "S-User".

Third tip, the "Account Name" should contain the "S-user-trial" entry and the "User name" should be the "S-User" - et voila

Clicking the Next button then allowed me to chose the SAP HANA instance:

And finally click "Finish".

Not surprisingly it contained some Enterprise Performance Management sample data:

Next stage, create some code and run it! Lucky find, I have a link in the instances section to the in browser development river:

And creating and saving a file is very easy by using right-click or the menu bar:

but there seem to be some differences in files which can be seen in the browser i.e. templates (above) and the local installation (below), the samples are missing:

Anyhow, I wanted to run the samples through the browser anyway.

Click on the run drop-down shows some different run modes iOS and Android as well (neat feature), although I couldn't detect the difference for the very simple HelloWorld sample:

selecting "Run" automatically shows:

in SAP UI5 style.

and now I have to write some code "To be continued ...", also next time I will add some information on data import using my local SAP HANA studio. Where is my schema again?

Part II

I may actually split this off into a seperate page, as this blog may get to long. But until then I will continue here, with the data import of my Excel sheets.

Right-click on the schema or catalogue only lets you import table dumps which have been created with SAP HANA Studio.

So instead we need to go via the quick-launch page and select "Import". If by accident you closed the quick launch page, it's accessible via "Help":

(Note: if you are using local HANA deployments or your first time, make sure you select a system using the button towards the top of the page)

And on the right-hand side we have "Import"

And under SAP HANA Content you can select Content. After selecting the xls file, and specifying my options ...

I had to choose my schema (note: it's not a "New Schema" it's a "New target table in an existing schema") and the list presented was very very long indeed. All the other cloud schemas were listed. I haven't tried publishing in someone else's schema, but I doubt it would work. In the end I found my schema, it helps to look at the name you connected your quick launch window to (see above screenshot).

Clicking the Next button, took a good 2-3minutes to bring up the next dialog box window. I doubt that large xls files in MB can be uploaded this way. If I would be using the paid version I am sure I could SSH/Putty a file to the server first and then use the sql IMPORT FROM command for a CSV file.

With regards to other cloud data, I have only found the option of an HCI oData connection which can draw from the SAP Business Suite:

Alternatively it should be possible to draw data in from another cloud web service via code using oData. But there doesn't seem to be a simple point and click scenario, where we can read the webservice/WSDL and create a table from it, including delta update requests.

Other connectors are not working like "Data provisioning", but I wouldn't expect them to work in SAP HANA Studio, as I don't host any SAP ECC / SLT servers in the same trial cloud to draw data from.

Coming back to my Excel spreadsheet, it showed a few flaws at first in the mapping screen. The source file (left side) had lines going from the title into the title on the right side. This may just be in the Mac version like this:

After a quick resize of the window this seems to have corrected itself.

Clicking Finish imported the data correctly, as mapped above.

Next I will make a start with coding - but in a different page <link goes here> 🙂

Labels in this area