cancel
Showing results for 
Search instead for 
Did you mean: 

Wrong Availability check for Header Item in Sales BOM after BOP

Former Member
0 Kudos

Hi Guys

I am stuck with a very weird problem. Request your advice:

I have a Sales BOM with one item Lets header is 'A' and Item 'B'. On creation of Sales Order ATP check is performed and both the line items (with A and B) the committed qty and committed date.

Now when BOP runs, it deletes the allocation of A and changes it to '0'

Details:

'A' is a non stockable product

Req:

1. I am not sure whether I should include A in BOP selection, however even running it only with B it deletes the allocation of A and the committed qty changes to '0'

Can you please suggest the solution or standard way of running BOP for Sales BOM

Thanks in advance

-Rahul

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Khanna,

We faced the same issue. Had even raised with SAP.

It seems you cannot handle allocation of header packs along with items in BOP (not supported in std GATP it seems).

GATP needs stock to be available on the Header to confirm allocation

The solution we have adopted is as follows.

- Block Items from participating in BOP based on item category exclusion filter.

- Before BOP run check stocks of items and header order qty and upload dummy stocks on the header.

- Carry out BOP

- Delete dummy stocks on header

We are not transferring BOP results directly to R/3, so Iam not sure how this process will impact results publishing to R/3. You may have to build some enhancements if there are some issues in publishing BOP results to APO.

You can also do it the other way round, prevent headers from participating by item category filter and carry out BOP only on items and then change the confirmed qty on header based on confirmed qty of items.

May be our experts can share if there is some other way also to handle this.

Regards,

Ashok

Former Member
0 Kudos

Thanks a lot Ashok for quick reply

Referring to your second suggestion, even if exclude the header item in BOP, and run only the item level materials (item B in my example above) the header item committed qty changes to 0

i guess it was possible in your case as you were not sharing the BOP results immediately as you said.

Also I am not able to replicate this issue completely in test environment, can you please say in your case, in which scenario you were facing this problem!

Thanks in advance

-Rahul

Former Member
0 Kudos

Hi,

In our case the confirmed qty for header would always be zero because BOP checked for stocks on the header code which will not be available.

And the header confirmed qty should not be reduced to zero if you had excluded it from allocation.

To my knowledge BOP happens at sales order line item level, so if you have not included the header in your BOP run it should not be affected. But as you said it could be because you are running BOP in update mode.

Pls check this...

Was the confirmed qty zero in APO or in R/3 after BOP results are published to APO?

Can you run BOP in post processing mode? in this case BOP will happen but results are not published to R/3.

You can see the results of the run in /sapapo/bop_result and then publish the results through /sapapo/bop_update.

Before publishing please check the confirmed qty of header in APO, is it affected?

We run BOP in post processing mode and faced the issue in this mode.

Regards,

Ashok

Former Member
0 Kudos

Hi Rahul

Did you also maintain any corelation profile in configuration? This is done in Customizing transaction spro / Advanced Planning and Optimization / Global Available-to-promise (Global ATP) / General Settings / Maintain Correlation Profile. Intended configuration is "Correlation: Reduce confirmed quantities (Correlate 0 Qty)". Please test it after this configuration. You may also check if you have implemented any user exit in ECC side.

Thanks,

Prasun

Former Member
0 Kudos

Thanks for your reply Ahsok and Prasun

Ashok, I did try Post Processing and then sending the update, it didnt help. as BOP cleares the allocation only the first time, and next time (on changes) it works fine! So not sure if I am getting your suggestion correct. Can you please be bit more specific.

Also do you mean every time before pushing the results the user need to check them! This will be cumbersome!

Prasun

We are using the standard Co-relation profiles and it has Corr.Confirm Mode as Correlation: Keep Confirmed qty

Can you please briefly explain me the use of these profiles, as I thought these are used only in CTP. It would be helpful if you can give a brief on this in this context also.

Again is this scenario falls under MultiATP Check !

Thanks in advance

Rahul

Former Member
0 Kudos

Hi Rahul

You may check Note 1135670 to get the details about this customizing. Though this note deals with an exactly opposite isse.

I would assume that you are also using a delivery group as part of Sales BOM in ECC, hence please test with the "Correlation" and "Correlation Group" in the BOP Batch Variant Worklist Tab.

Thanks,

Prasun

Former Member
0 Kudos

Thanks Prasun

However I have already done the Correlation Check in the BOP, it didnt work

The result shows the Component qty is committed (it has not changed: and green light) but the header item shows red light not committed. Header item is non stockable item !!!

Also the OSS note was not relevant as you said. However we have correlation profile of 'keep the committed qty'.

Does that rings any bells!

Kindly suggest!

Thanks in advance

RK

Former Member
0 Kudos

Hi

Can you check if you have excluded header item category from BOP Filter as suggested by expert Ashok? If yes, please also check BOP Worklist or BOP Monitor to see if are Header item still exist. If you exclude Header Item Category, you should not be able to see it anymore in BOP Worklist or BOP Monitor.

From ECC side, please also check if you have any user exit implemented or complete delivery flag is set.

Thanks,

Prasun

Edited by: PrasunM on Feb 2, 2012 1:54 PM

Former Member
0 Kudos

Thanks Prasun and Ashok

Can you please tell me bit more when you say: "excluded header item category from BOP Filter"

I havent explicitly excluded anything. However as the header item is Non Stockable so I guess it can be the case! And so when I use Correlation option in the BOP worklist, it shows up however even when the line item shows green, the header item is red for few!!

Not sure why this happens. So please let me know where can I check if this header item is excluded some how!

Or any other links / suggestion towards solution please

Thanks in advance

RK

Former Member
0 Kudos

Hi RK

Step 1 : You need to define a new filter type or modify existing filter filter type. The path is SPRO -> GATP > BOP -> Maintain Filter Type. Choose Filter type and double click on criteria on left pane. You need to add Item Category (PSTYV) in the criteria.

You can also get the details from http://help.sap.com/saphelp_SCM700_ehp02/helpdata/en/45/8e2c9855de40c0e10000000a1553f7/frameset.htm

Step 2: Then you need to go to the existing variant for /SAPAPO/BOP, in the worklist tab, choose the filter type that you have defined in step 1 and click on the filter on the right of field Filter Variant. You need to go to the document tab and you should be able to see a field for Item Category. There you should exclude the item category for Header. You need to save this filter variant and execute. You may also click on "Display List" to see the line items getting selected - it should exclude Header item. Thereafter save BOP Variant with this filter variant.

Step 3: Run BOP with this variant and check whether header items are still appearing in BOP Worklist.

Let me know if you still see Header Items.

Thanks,

Prasun

Former Member
0 Kudos

Thanks a lot Prasun

I followed your instruction however wile adding the Item Category field in the Filter type, it threw information stating 'it cannot be used for BOP'

Even proceeding with that didnt help as I could not select any value in the BOP for this field!

Can you advice on this further , please

Thanks in advance

-RK

Former Member
0 Kudos

Hi RK

I tried the same in our IDES Box (ver 5.0) and did not face any issue. Which version are you using?

I believe you were trying to modify some existing variant. I suggest that you try to create a new filter type, new filter variant and new BOP variant in your development box and then test it. Please also share your filter type configuration (order categories and criteria).

Thanks,

Prasun

Former Member
0 Kudos

Thanks for writing in Prasun

Yes I created a new Filter type however when you add a STO category and then you change the fields to include item category you will get the same error. I am also in V 5.0 of SCM

Normally we use SAP_NetChange filter type. So is it possible to restrict using item category for this filter some how!

On the otherhand I also wonder these should not ATP relevant as the header item is non stockable item! And I guess there should some catch to exclude if not item category as you mentioned!

So the order categories included are:

Customer Inquiry

Customer quotation

Sales Order

SD Scheduling Agreement

SD Scheduling agreement w/external

Contract

Delivery w/io charge

Independent requriement

Release from customer in plant

STO

Deplyometn release

TLB release for purc ord

Fields

Product

location

distribution centrer

MRP area

product Hierarchy

Location hierarchy

supplier location

These are std filter type and I cant be modified.. however we restrict our filter to location only!

Kindly advice!

Thanks in advance

-RK

Former Member
0 Kudos

Hi RK

I am not sure why you are using so many order categories and fields in a single filter type. You may want to re-look the same depending on the business requirement. Since this issue you are facing only for Sales Order, try to test by creating a new filter type only with Order Category Sales Order (BM) and Fields as per your requirement (say Product, Location and Item Category). If you are getting an error, I would suggest to raise an OSS Message in parallel.

Thanks,

Prasun

Former Member
0 Kudos

Thanks a lot for writing in Prasun

While I am trying on your suggestion, a very quick qst based on your response:

1. The filter type I am using is Standard SAP: SAPNETCHANGE, and all the categories are included in it. This uses the Planning file so helps better performance. Not sure if a Z Filter type can use the plannig file, or please let me know on this

2. Also if I create two separate filter and run them separately, how will it distribute/allocate the stock between Sales Order and STO ... say based on the Delivery date

Kindly let me know on these

Thanks in advance

RK

Former Member
0 Kudos

Hi RK

1. I do not think a Z Filter will consider Planning File entry, but I am not very sure. Do you have any specific reason for choosing this option? Performance may also be accpetable for z filter provided volume etc is adjusted among variants.

2. I have told you to create a separate filter for SO only for test purpose. For most of the cases that I have seen, they want them to go on the same filter as available stock can be more judiciously distributed at one go based on sort criteria.

Thanks,

Prasun