cancel
Showing results for 
Search instead for 
Did you mean: 

SEM-BCS Flatfile Breakdown

Former Member
0 Kudos

Hello to you all,

after I set up BCS 6.0 and activated the content I had to fix some problems and there are still some. This is one of them:

I need to upload the "account types" and the Flatfile has text instead of numbers for the types (e.g. "possible breakdown: initial allowed")

The Problem is I don't know which type is which number. So I don't know how to set up the flexible upload for it.

Any answers and announcements would be great : )

Benjamin Maier

Accepted Solutions (1)

Accepted Solutions (1)

dan_sullivan
Active Contributor
0 Kudos

One way to get this information is in the BCS workbench (UCWB) go to the Master data > Subassignments > Breakdown Categories, right mouse click and choose list settings. Then change to view to include both the breakdown type description and breakdown type value.

The easy answer is:

0 = no breakdown

1 = optional, initialized (blank) value allowed

2 = required, if blank use default

3 = required, entry is forced, default allowed

4 = required, entry is forced, default not allowed

Former Member
0 Kudos

thank you. I found it myself allready. But you still can have the points for the answer ; )

Answers (9)

Answers (9)

Former Member
0 Kudos

Benjamin,

Everything you provided is looked fine to me, for example, field names like /1FB/MOVE_TYPE.

However, there are settings DEPENDENT AND NOT DEPENDENT on cons area. So, if it's not so difficult, please specify in the method header the cons area and language.

Former Member
0 Kudos

Benjamin, now I can to look at your problem quietly.

First of all, you need to specify the HEADER of the upload structure: the cons area & language. Without it it shouldn't work. Try!

Former Member
0 Kudos

I am sorry, but I don't need that.

I use global parameters and I start the flexible upload right in the left hand menü of uswb.

That is no problem : )

I did already a lot of uploads. Positions, movement types, financial data, etc pp...

But I could not solve this problem with uploading of acount types yet.

I got a colum of the acount type, the description, the breakdown type, the value and at the end that stupid (sorry) breakdown category (for example: "allocated company, currency, partner, company,.." etc.).

And my flatfile is not correct. There are those "description" in it. I don't know which syntax and which value I have to put in there.

Nobody could help me yet : (

(I am out now ; ) c u tomorrow)

Former Member
0 Kudos

Hi Benjamin,

Not sure that I got your problem.

Are you talking abt upload file for subassignment types? If yes, then create a new flexible upload method for subassignments, and a file for upload with the structure corresponding to the method.

In every new system you'll have only create a flexible upload method (5 minutes) and upload the types.

Hope this helps.

Former Member
0 Kudos

Hi Eugene,

that is what I tired, but I have not Flatfile to upload. My Flatfile is not correct because it is from another system. Just like the Screenshot above shows.

I need the correct input for the colum "subassignment".

I'll upload some screenshot with english input. mom.

Former Member
0 Kudos

This is how the flexible upload looks like:

<a href="http://img210.imageshack.us/img210/3955/breakdowncategoriescf3.jpg">upload</a>

and this is how my flatfile looks like (short and with english descrp., hope it is correct translated):

<a href="http://img294.imageshack.us/img294/9968/flatfilewh2.jpg">flatfile</a>

in excel (german):

<a href="http://img515.imageshack.us/img515/6948/excelflatfilewo2.jpg">flatfile excel</a>

As you can see in the .txt I tried to put in the technical fieldnames but that doesn't work. : (

I also found this by searching for usage of "UC_Fieldname" which is assigned to the field with that "alloc. comp." etc.

[url=http://img124.imageshack.us/img124/5505/usfieldnameww8.jpg]uc_fieldname[/url]

Former Member
0 Kudos

Do you have a flatfile for me to upload?

Former Member
0 Kudos

I went the way SAP Info tells me, but there is no value in that table.

For example "UC_breakdown" contains

0 - no breakdown

1 - ...

...

4 - must breakdown etc...

But "UC_Fieldname" of course has no value range.

That is my problem. I just don't know what my flatfile has to look like, that I can upload it correctly.

This is the table for possible entrys:

<a href="http://img212.imageshack.us/img212/4307/possibleentrys01lz1.jpg">Possible Entrys BCS4.0</a>

Former Member
0 Kudos

.

Former Member
0 Kudos

The last thing I can propose is to reinstall the latest version of SAPGUI.

Former Member
0 Kudos

I got this version:

fileversion: 6405.5.26.3057

build: 917864

patch-level: 26

Can't believe an update for the SAP-Gui would change anything.

Former Member
0 Kudos

Hi Eugene,

I got the same problem again. Problem is: I cannot copy account types because it is a other field catalog. I have not the time always to create every single type in every new database. Do you know where I can get a uploadable flatfile for account types or how I can solve this problem in another way maybe?

Thanks a lot in advance!

Screenshot of my Flatfile: <a href="http://img382.imageshack.us/img382/1088/kontierungstypenkm9.jpg">account types</a>

greetings

Benjamin Maier

Former Member
0 Kudos

SO, you didn't solve the problem. Not for all items in dropdown menu you'll be able to see the info in help.

It is either really your very-very slow server, or you did (or didn't ) something very-very-very trivial.

I was looking for the solution of your (mine in the past) problem for several days. When I found it, everything was shown with the proper codes/IDs.

Update us with the results.

Former Member
0 Kudos

Hi,

I am also try the "Show keys in all dropdown list" but the breakdown category still have no ID. So Benyamin, if you have found the solution, please let us know

Thanks.

Former Member
0 Kudos

Sign off and sign in again, for sure.

Former Member
0 Kudos

: ) I am sorry, I did that 10 times ; ) It just doesn't.

nvm. I solved my problem. Thanks a lot

Former Member
0 Kudos

How have you solved it, if it is not a secret?

Former Member
0 Kudos

I just used the table in the help for SEM-BCS. There is a table with

0 = no breakdown

1 = optional, initialized (blank) value allowed

2 = required, if blank use default

3 = required, entry is forced, default allowed

4 = required, entry is forced, default not allowed

Maybe the changes work till tomorrow ;D Slow Server ;D no no..

Nevermind.

Former Member
0 Kudos

OK, Benjamin,

Here is a path.

Enter the system. Click on the most right icon (Customizing of local layout (Alt + F12)), Options, Expert tab. Tick the 'Show Keys in all Dropdown Lists' flag.

Now all your descriptions in dropdown lists will follow the key of the list item. It will allow you easily understand which description to which ID (key) corresponds.

Former Member
0 Kudos

Hi Eugene,

did I understand it right, that option will only sort them top-down, right?

I still don't see any numbers/IDs in that drop-down.

BR

Former Member
0 Kudos

Hi Benjamin,

AFAIU, your problem is: the dropdown lists don't show the key of the item, it shows just a text of the item (instead of "0 No breakdown", ir shows "No breakdown" only?

If yes, then click the Option (or Settings) button (do not have the system febore me, so I might be a little free in terms) -- it's the last right button on the upper bar without any descriptions and with different color rectangulars in the icon. Find there an "Expert mode" and tick the appropriate option.

You'll see the proper code and will be able to provide these codes in files.

Former Member
0 Kudos

Hi Eugene,

thanks for you answer, but I can't find what you told me.

I made a screenshot(sorry, the methods are in German, but I starded SAPlogon with English) so I show you which items I mean. But what I had to solve was the corresponding connection between those numbers (ID's) that the system uses and its associated description.

<a href="http://img352.imageshack.us/my.php?image=screenshotbreakdownvp3.jpg">Image (Screenshot)</a>

My problem now was, I have an csv Flatfile with only the description in it, but not the numbers. But the upload needs the IDs and not the description. So I searched for the connection between them and I found them in the documentation from sap sem.

: )

But I would really appreciate it if you tell me exactly where I can switch on that expert mode. I didn't find it.

I open the breakdown category and the only options I found was that "Edit" -> "Settings" which are those general workbench-settings.

Thanks a lot in advance.