cancel
Showing results for 
Search instead for 
Did you mean: 

Kit to stock process, triggered from EWM

JuergenPitz
Product and Topic Expert
Product and Topic Expert
0 Kudos
1,407

Hi,

has anyone here ever managed to get a kit-to-stock process running? In general my process is working, I have a VAS order, an outbound delivery order and an inbound delivery. But both deliveries in EWM use the same BP. As this BP is a vendor, of course the outbound delivery order shows an error and does not create the outbound delivery in ERP. All settings I can think of are done, but still no success. Any pointers what I am missing?

Brgds

Juergen

Accepted Solutions (1)

Accepted Solutions (1)

MatthiasSchilka
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Jürgen,

without having checked details in the System, i would assume the BP used for inbound - and outbound deliveries is the one maintained in /SCWM/LGNBP.

This BP should be maintained with all 3 ID Types (CRM002, CRM004, CRM011) and roles of vendor and customer.

Did you check this?

Let me know if this doesnt help.

Matthias

JuergenPitz
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Matthias,

in this transaction I have to assign the SCU, the Custodian, the Default Party Entitled to Dispose, and the Default Ship-To. I suppose I can disregard the SCU and the Custodian, as they could not be it. The Default Entitled to Dispose is tricky, because it is the Default. So what in a multi-client warehouse? Anyway, in the /SCWM/VAS_KTS, you enter you Ent. to Dispose, so it is not necessary. Which leaves the Default Ship-to. But this one is not used. I have entered one, but does not work.

A BP in standard can not have all three roles. Because it is either a vendor (so CRM004) or a customer (CRM002) (Except if you would use the BP mapping because you used the same number in ERP). And only of of them has the ID Type CRM011. I can also not assign CRM002 or CRM004 manually (Error: You may not enter any numbers in the dialog for ID Type CRMxxx).

What I am missing the connection that the other BP is found in this process. I enter the entitled to dispose, which is a Vendor, and the system must find the BP for the other "direction", in this case a customer.

Brgds

Juergen

(and just to confirm: in our warehouse the SCU, the Custodian and the default entitled to dispose are all the same).

MatthiasSchilka
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Jürgen,

still guessing it´s the Default entitled from /SCWM/LGNBP.

A BP can have all 3 id types in Standard as BP can be a "representative" of ECC vendor  and ECC customer and plant. The mapping of ECC vendor and customer is done in TX BP in the tab "identification".

For the maintenance of the BP with the 3ID types you might Need to Change some BP customizing settings. Pls check SPRO-Cross Components-SAP Business Partner-Business Partner-Basic Settings- ID numbers - define id types and remove the flag "Display only". This should enable you to maintain the entitled BP with all 3 ID types.

Check this and try again.

If it´s not working let me know which System and i can check.

Cheers,

Matthias

JuergenPitz
Product and Topic Expert
Product and Topic Expert
0 Kudos

Ah, that did the trick. After removing the "Display only" flag it works. Just one change: the setting is under "Define Identification Categories".

The outbound delivery order in EWM still looks strange because it has the BP which is a vendor as ship-to-party and when you check the ODO it gives a warning "Business partner xxx not allowed for document role STPRT" - but the action for sending the delivery to ERP now works.

Great, thanks a lot!

Juergen

Former Member
0 Kudos

Hi experts,

I am also facing the same problem. Direct ODO created with kit to stock VAS order has vendor as BP. So system failed to generate the message through PPF action to replicate the ODO to ECC. After maintaining customizing settings-define id types and remove the flag "Display only" at SPRO-Cross Components-SAP Business Partner-Business Partner-Basic Settings- ID numbers, system is able to generate the message successfully but it got stuck in inbound queue of ECC now for the following error:

Did any of you encounter this problem? Any solution on this?

Thanks,

Sudhir

Answers (2)

Answers (2)

0 Kudos

Hello Juergen,

Thank you for your quick reply! My current setup is based on two different BP for a Plant, Vendor and Customer BP. For Kitting Scenarios where VAS generation the Outbound Delivery in EWM directly, the system seems to pick up only the VENDOR and not the CRM002/CRM000 Customer. I had the impression that you had the same issue while back when you posted this question.

My question is, will EWM (9.4) is able to pick up the CUSTOMER when generating VAS related ODO from EWM or I just missed something?

Thanks in advance for your help.

Tamas

0 Kudos

Hello Jurgen

Were you able to manage the "Business partner xxx not allowed for document role STPRT" problem? In my experience, the system shows it when CRM002 is not assigned to the BP what you are using but at your case was a VENDOR for the Plant and not the Customer.

I have the same problem, the system does not seem to determine the Customer for KITTTING ODO. Since your message is old, I assume you were able to come across this problem.

Can you please share it how? Would be a great help.

Regards,

Tamas

JuergenPitz
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello tamas.zsolnai ,

well the solution is what was described above: you have to change the BP settings so that you can assign CRM002 manually to the one BP. The problem is that this is build up on something which is contradicting every other description: that there is ONE BP which is for customer and vendor. Everywhere else we describe that there are two BPs for these two roles.

The better solution came with S/4HANA 1909 (eventually it is already available in 1809 FP02). In there is a new table where you assign the customer and vendor to be used for a plant. This information is used for TCD and Kit to stock.

Brgds

Juergen